Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 170213 - Line comments are lost when introducing method
Line comments are lost when introducing method
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
:
: 172066 (view as bug list)
Depends on: 175020
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-11 15:35 UTC by Jiri Prox
Modified: 2009-10-28 11:33 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2009-08-11 15:35:05 UTC
Product Version: NetBeans IDE Dev (Build 200908110201)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Linux version 2.6.24-23-generic running on i386; UTF-8; en_US (nb)

Line comments are lost when introducing method.

Steps to reproduce:
1) select several lines where some contains line comments
2) introduce method from selection
-> inline comments are lost
Comment 1 Jan Lahoda 2009-08-20 09:57:44 UTC
Reassigning all moonko's java/source bugs to myself.
Comment 2 Jan Lahoda 2009-09-14 08:59:00 UTC
*** Issue 172066 has been marked as a duplicate of this issue. ***
Comment 3 Jan Lahoda 2009-10-27 23:13:36 UTC
The part in java.hints was quite simple:
http://hg.netbeans.org/main-silver?cmd=changeset;node=6164f16b62a7
but it also required non-trivial changes in codegen:
http://hg.netbeans.org/main-silver?cmd=changeset;node=a9711e857d8b

As a consequence, comments handling in codegen may be less forgiving - some clients that did not do
importComments/copyComments so far might need to do that now, etc. This especially relates to clients that add/remove
statements to method bodies. David, Petr, if you see any suspicious problems regarding Java code generation and
comments, please, let me know, I will look at them. Thanks.
Comment 4 Quality Engineering 2009-10-28 11:33:38 UTC
Integrated into 'main-golden', will be available in build *200910280201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6164f16b62a7
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #170213(first part): introduce method should correctly copy comments.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo