Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 170204 - PHP needs metadata caching per project and global
PHP needs metadata caching per project and global
Status: RESOLVED DUPLICATE of bug 166340
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Jancura
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-11 14:37 UTC by mbirth
Modified: 2009-08-12 12:16 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mbirth 2009-08-11 14:37:02 UTC
When opening NetBeans, it always scans the global include path for PHP files (PEAR, PECL, etc.) which already takes its 
time. After opening a project with lots of files, it takes ages until all is scanned. Until the scan is finished, 
NetBeans runs sluggish and the Navigator is not usable.

Since we mostly work with the eZ Publish CMS which consists of hundreds (if not thousands) of files, you often need 5 or 
more minutes before you can start working on a project.

We'd need some metadata caching so that the navigator, syntax hints, etc. work directly after opening a project. The data 
could be updated on-the-fly when opening files. There should also be a manual way to trigger updating the cache.
Comment 1 Tomas Mysik 2009-08-12 09:18:36 UTC
Not PHP area, reassigning, please evaluate.
Comment 2 Vitezslav Stejskal 2009-08-12 12:16:50 UTC
Files crawling and up-to-date check of the indexed files is now much faster in dev builds.

*** This issue has been marked as a duplicate of 166340 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo