Bug 169958 - [Change Parameters] Performance of Change Method Parameters
[Change Parameters] Performance of Change Method Parameters
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Refactoring
6.x
All Windows XP
: P3 (vote)
: 7.0
Assigned To: Jan Becicka
issues@java
:
Depends on: 199085 183606
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-06 08:16 UTC by stefan79
Modified: 2011-06-01 14:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
The Snapshot while refactoring. (111.22 KB, application/octet-stream)
2009-08-06 08:30 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2009-08-06 08:16:59 UTC
The performance while "Change Method Parameters" isn´t good.
To add one Parameter to a Method, i need some minutes.
The strangest thing is, that after pressing the add-Button in the Dialog, I have to wait 3 Seconds before a new row in
the table is inserted.

I´ll attach a Snapshot.

-----
Product Version: NetBeans IDE Dev (Build 200908022240)
Java: 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02
System: Windows XP version 5.1 running on x86; Cp1252; de_AT (nb)
Userdir: G:\.netbeans\6.8m1
Comment 1 stefan79 2009-08-06 08:30:44 UTC
Created attachment 85887 [details]
The Snapshot while refactoring.
Comment 2 Jan Becicka 2010-10-04 14:41:39 UTC
it is caused by slow network drive, isn't it?
Comment 3 Vladimir Voskresensky 2010-10-04 15:15:16 UTC
not completely true.
I had slow access to my "home" dir, but all refactored sources are on local machine.
Probably is connected with #183606 (see my comment #5)
Comment 4 stefan79 2010-10-04 15:39:33 UTC
Every sources class-Files are on a local drive.
Comment 5 Jan Becicka 2010-11-12 11:02:25 UTC
Hm. But source cache and index files are in your home dir, which is expected to be fast. Please put your netbeans home dir on disk with fast access.
wontfix or duplicate of 183606


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo