Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 169565 - Test of an interface creates inner class that *extends* it
Test of an interface creates inner class that *extends* it
Status: RESOLVED DUPLICATE of bug 172723
Product: java
Classification: Unclassified
Component: JUnit
6.x
All All
: P4 (vote)
: TBD
Assigned To: Victor Vasilyev
junit-issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-30 14:07 UTC by pribyl
Modified: 2009-11-16 07:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pribyl 2009-07-30 14:07:56 UTC
Product Version: NetBeans IDE Dev (Build 200907300201)
Java: 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

If you create a test for java Interface (e.g. MyInterface) with some method (public void foo()), the file
"MyInterfaceTest" contains:

public class MyInterfaceImpl extends MyInterface { ...

with error badges "no interface expected here" and "incompatible types".

Once "extends" is changed to "implements", it works just fine.
Comment 1 Victor Vasilyev 2009-11-16 07:28:54 UTC

*** This bug has been marked as a duplicate of bug 172723 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo