Bug 169460 - AWT thread blocked.
AWT thread blocked.
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 169906 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-29 14:19 UTC by Jiri Prox
Modified: 2009-10-02 23:32 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (39.74 KB, bin/nps)
2009-07-29 14:19 UTC, Jiri Prox
Details
nps snapshot (12.16 KB, bin/nps)
2009-08-12 15:31 UTC, jmichelberger
Details
nps snapshot (19.04 KB, bin/nps)
2009-08-13 12:30 UTC, jmichelberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2009-07-29 14:19:16 UTC
Build: NetBeans IDE Dev (Build 200907280201)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.24-23-generic, i386

User Comments:
jiriprox: Switching and editing files


Maximum slowness yet reported was 4309 ms, average is 4309
Comment 1 Jiri Prox 2009-07-29 14:19:25 UTC
Created attachment 85452 [details]
nps snapshot
Comment 2 Max Sauer 2009-08-11 09:36:08 UTC
Tome, please have a look. AWT waits for probably canceled parser. Thanks.
Comment 3 Max Sauer 2009-08-11 09:47:07 UTC
*** Issue 169906 has been marked as a duplicate of this issue. ***
Comment 4 Exceptions Reporter 2009-08-11 13:18:30 UTC
This issue already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=154462
Comment 5 jmichelberger 2009-08-12 15:30:56 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-3702-on-090810)
VM: Java HotSpot(TM) Client VM, 14.1-b02, Java(TM) SE Runtime Environment, 1.6.0_15-b03
OS: Windows XP, 5.1, x86

User Comments: 

Maximum slowness yet reported was 27610 ms, average is 8569
Comment 6 jmichelberger 2009-08-12 15:31:01 UTC
Created attachment 86156 [details]
nps snapshot
Comment 7 Exceptions Reporter 2009-08-12 15:31:05 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=154462
Comment 8 jmichelberger 2009-08-13 12:30:20 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-3702-on-090810)
VM: Java HotSpot(TM) Client VM, 14.1-b02, Java(TM) SE Runtime Environment, 1.6.0_15-b03
OS: Windows XP, 5.1, x86

User Comments: 

Maximum slowness yet reported was 27610 ms, average is 7865
Comment 9 jmichelberger 2009-08-13 12:30:25 UTC
Created attachment 86191 [details]
nps snapshot
Comment 10 Exceptions Reporter 2009-08-13 12:30:30 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=154462
Comment 11 Tomas Zezula 2009-09-24 14:04:33 UTC
The CodeTeplateFilter takes the time.
Comment 12 Dusan Balek 2009-09-24 17:27:21 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/ccd67f9792db


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo