Bug 169037 - Allow sending link to an issue
Allow sending link to an issue
Status: VERIFIED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Chat
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Petr Dvorak
issues@connecteddeveloper
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-23 12:52 UTC by Petr Dvorak
Modified: 2009-10-26 15:37 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Dvorak 2009-07-23 12:52:19 UTC
It should be possible to send a link to an issue (pattern "issue [0-9]+"?) and open the issue from the IDE (in the IDE UI).
Comment 1 Jan Becicka 2009-08-05 21:16:51 UTC
Petre, you can try this one.
Comment 2 Petr Dvorak 2009-08-06 10:05:35 UTC
Yes, I'll have a look.
Comment 3 Petr Dvorak 2009-08-07 10:34:11 UTC
Fixed in cdev: http://hg.netbeans.org/cdev/rev/1e9145e5d2da

How it works:

- Kenai project must have an issue tracker for the links to be recognized
- Bugzilla issues are opened in the IDE, Jira issues are opened in the browser
- patterns "issue 123", "issue #123", "bug 123" and "bug #123" are recognized
- for jira, the form "bug JIRA_ISSUE-123" is equivalent with "bug 123" (the project name does not have to be included)
- for bugzilla, if you specify an issue that is not in your project, it gets opened (problem with the fact that the
issue numbering is global for BZ). You can see that the issue is not in your project in the issue details.
Comment 4 Quality Engineering 2009-08-07 17:57:55 UTC
Integrated into 'main-golden', will be available in build *200908071401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/1e9145e5d2da
User: joshis@netbeans.org
Log: #169037 - Implemented issue recognition in the Kenai chat
Comment 5 Petr Dvorak 2009-10-26 15:37:57 UTC
Verified, done for 6.8


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo