Bug 168734 - deadlock after IDE restart during initial projects opening
deadlock after IDE restart during initial projects opening
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@editor
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-17 10:47 UTC by David Konecny
Modified: 2009-09-11 21:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (22.26 KB, text/plain)
2009-07-17 10:47 UTC, David Konecny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Konecny 2009-07-17 10:47:28 UTC
Please evaluate and reassign if deadlock lies in some other modules. Thx.
Comment 1 David Konecny 2009-07-17 10:47:55 UTC
Created attachment 84880 [details]
stacktrace
Comment 2 David Konecny 2009-07-17 10:48:27 UTC
  Product Version         = NetBeans IDE Dev (Build 090715) (#5c4f8f0e5379)
  Operating System        = Linux version 2.6.24-24-generic running on i386
  Java; VM; Vendor        = 1.6.0_14; Java HotSpot(TM) Client VM 14.0-b16; Sun Microsystems Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_14-b08
 
Comment 3 Jan Jancura 2009-07-20 12:21:18 UTC
TaskProcessor lock is private and safe.
This issue is caused by:
Reformatter.reformatLock ()
or
JavaSourceAccessor.lockJavaCompiler ()

see #168610
-> formatting
Comment 4 mslama 2009-07-21 12:05:49 UTC
Are you able to reproduce it? What projects was opened? I will try to add some logging but if there is deadlock I need
to find out some way how to start check.
Comment 5 mslama 2009-07-21 12:11:11 UTC
Do you have IDE log? I want to check if there is any exception. During IDE start there is no IDE indentation/reformat IMO.
Comment 6 mslama 2009-07-21 13:18:45 UTC
It is deadlock between parsing.api and projectsapi. Passing back to parsing.api. So problem is not with unreleasing lock.

Threads: "Load Open Projects" and "Parsing & Indexing Loop (090715)"
Comment 7 Jan Jancura 2009-07-21 13:57:00 UTC
true +> indexing
Comment 8 Vitezslav Stejskal 2009-07-24 09:52:10 UTC
Thanks for evaluating this. I'll try to fix it somehow.
Comment 9 Tomas Zezula 2009-09-09 14:39:49 UTC
Fixed in jet-main: 2143554a0189
Comment 10 Quality Engineering 2009-09-11 21:44:36 UTC
Integrated into 'main-golden', will be available in build *200909111401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/2143554a0189
User: Tomas Zezula <tzezula@netbeans.org>
Log: #168734:deadlock after IDE restart during initial projects opening


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo