Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168701 - cannot use jpda debugger until new project is created
cannot use jpda debugger until new project is created
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@debugger
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-16 17:08 UTC by Filip Zamboj
Modified: 2009-07-23 17:49 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Change in dependencies that fixed the problem on the 6.7.1/rc/2009-07-16_23-01-10 build (2.29 KB, patch)
2009-07-22 16:45 UTC, Jaroslav Tulach
Details | Diff
Smaller change in dependencies, just using Recommends tag (551 bytes, patch)
2009-07-22 17:29 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Zamboj 2009-07-16 17:08:49 UTC
Product Version: NetBeans IDE 6.7.1 RC (Build 200907150227)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02
System: Linux version 2.6.28-13-generic running on amd64; UTF-8; en_US (nb)


1. install netbeans 6.7.1rc using installer 
2. open it with empty userdir 
3. open existing J2SE project 
4. try to toggle breakpoint or try to debug project <- doesn't work 

reproduced after netbeans restart as well. Debugging started to work once a new project was created.
Comment 1 Filip Zamboj 2009-07-16 17:14:29 UTC
this is not reproducible if you download .zip. It looks like installed version problem only. 
Comment 2 Daniel Prusa 2009-07-17 15:26:10 UTC
Just for completeness, this problem occurs only if javafx module is present and affects also other modules (e.g. form
editor).
When an existing J2SE project is opened, not all needed modules are automatically enabled.
It is related to ergonomics and javafx is somehow involved.
Comment 3 Martin Entlicher 2009-07-20 10:17:35 UTC
This looks like it needs to be solved in ergonomics - all JPDA debugger modules need to be enabled.
Comment 4 Marian Mirilovic 2009-07-20 10:20:46 UTC
Ok, guys this is stopper for NB 6.7.1 . 

Filip, are you still able to reproduce it even after latest changes in javafx ?
Comment 5 Filip Zamboj 2009-07-20 10:51:00 UTC
it's still reproducible in 
Product Version: NetBeans IDE 6.7.1 RC (Build 200907162301)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02


i'll check if there is any more up-to-date build 
Comment 6 Filip Zamboj 2009-07-20 11:02:03 UTC
not reproducible in 
Product Version: NetBeans IDE 6.7.1 (Build 200907192301)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02

=> fixed 
Comment 7 Filip Zamboj 2009-07-20 11:02:42 UTC
verified
Comment 8 Marian Mirilovic 2009-07-20 13:24:58 UTC
Martin/Petr/Jarda ... is this already fixed ? ... or do you plan to fix it different way into trunk ?
Comment 9 Jaroslav Tulach 2009-07-22 16:43:22 UTC
Dependencies of debugger.jpda.ui are weird. It depends on java.kit while it shall be opposite - java.kit shall require 
presence of JPDA debugger UI.
Comment 10 Jaroslav Tulach 2009-07-22 16:45:09 UTC
Created attachment 85077 [details]
Change in dependencies that fixed the problem on the 6.7.1/rc/2009-07-16_23-01-10 build
Comment 11 Jaroslav Tulach 2009-07-22 17:29:48 UTC
Created attachment 85078 [details]
Smaller change in dependencies, just using Recommends tag
Comment 12 Martin Entlicher 2009-07-22 17:33:50 UTC
Reviewed. debugger.jpda.ui serve as a kit - it enables whole Java Debugger.
This fix will correctly enable whole Java Debugger when java.kit is enabled. Thanks.
Comment 13 Jaroslav Tulach 2009-07-22 17:37:44 UTC
core-main#9c3ac607484c
Comment 14 Jaroslav Tulach 2009-07-22 17:44:37 UTC
release67_fixes#9c3ac607484c
Comment 15 Vojtech Sigler 2009-07-23 13:51:42 UTC
Verified in 6.7.1 (Build 200907230233)
Comment 16 Quality Engineering 2009-07-23 17:49:13 UTC
Integrated into 'main-golden', will be available in build *200907231401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9c3ac607484c
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #168701: java.kit shall trigger whole Java debugger if available


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo