Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168613 - Deadlock
Deadlock
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
67patch2-verified
:
: 168888 169738 169831 170529 170615 170796 171201 171693 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-15 13:52 UTC by David Strupl
Modified: 2009-09-08 14:58 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump when the IDE is frozen. (32.56 KB, text/plain)
2009-07-15 13:53 UTC, David Strupl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Strupl 2009-07-15 13:52:18 UTC
Using a build from 13.7.2009. I will attach a thread dump.
Comment 1 David Strupl 2009-07-15 13:53:05 UTC
Created attachment 84776 [details]
Thread dump when the IDE is frozen.
Comment 2 Martin Entlicher 2009-07-21 09:36:48 UTC
Locks in UnionTreeModel are problematic.
Comment 3 Martin Entlicher 2009-07-21 14:48:38 UTC
*** Issue 168888 has been marked as a duplicate of this issue. ***
Comment 4 Martin Entlicher 2009-07-21 15:17:46 UTC
Fixed in changeset:   138682:bd98d569d7f5
http://hg.netbeans.org/main/rev/bd98d569d7f5
Comment 5 Quality Engineering 2009-07-23 07:42:38 UTC
Integrated into 'main-golden', will be available in build *200907230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/bd98d569d7f5
User: mentlicher@netbeans.org
Log: #168613 - Synchronization of access to cached values is changed to prevent from deadlocks.
Comment 6 Martin Entlicher 2009-08-04 15:47:44 UTC
*** Issue 169738 has been marked as a duplicate of this issue. ***
Comment 7 Martin Entlicher 2009-08-04 15:49:09 UTC
According to issue #169738 this deadlock was introduced also into 6.7.1 builds. Therefore this should be subject of a
patch to 6.7.1.
Comment 8 dartme18 2009-08-04 19:54:53 UTC
*** Issue 169831 has been marked as a duplicate of this issue. ***
Comment 9 Martin Entlicher 2009-08-05 10:01:51 UTC
Setting version to "6.7" - unfortunately we do not have "6.7.1"! This bug was introduced with other patches into 6.7.1.
Upgrading priority to P1 due to the number of reports we get.
Comment 10 Vojtech Sigler 2009-08-05 10:14:43 UTC
Shame that I did not discover this in 6.7.1 during testing. However, I am not sure what can be done now since patch1 is
already out. I do not know about any plans for patch2. I'll see what I can do.
Comment 11 Martin Entlicher 2009-08-18 10:35:31 UTC
*** Issue 170529 has been marked as a duplicate of this issue. ***
Comment 12 Daniel Prusa 2009-08-24 13:09:29 UTC
*** Issue 170796 has been marked as a duplicate of this issue. ***
Comment 13 Martin Entlicher 2009-08-25 13:51:34 UTC
*** Issue 170615 has been marked as a duplicate of this issue. ***
Comment 14 Martin Entlicher 2009-09-01 10:09:03 UTC
*** Issue 171201 has been marked as a duplicate of this issue. ***
Comment 15 Vojtech Sigler 2009-09-02 12:59:56 UTC
I'm no longer able to reproduce the issue in trunk build 200909011401 (debugged netbeans, did continuous Step Overs for
more than an hour) -> marking as verified
Comment 16 pgebauer 2009-09-02 16:31:27 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/0895a2ddd73b
Comment 17 Vojtech Sigler 2009-09-03 14:52:19 UTC
Verified in updated 6.7.1
Comment 18 Martin Entlicher 2009-09-08 14:58:43 UTC
*** Issue 171693 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo