Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168388 - Deadlock when create Maven project
Deadlock when create Maven project
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@java
67patch1-verified
: RANDOM, THREAD
: 167613 167645 168635 168885 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 10:39 UTC by Petr Blaha
Modified: 2009-10-19 14:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (30.71 KB, text/plain)
2009-07-10 10:39 UTC, Petr Blaha
Details
Proposed patch - please review (1.53 KB, text/plain)
2009-07-14 10:41 UTC, Vitezslav Stejskal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Blaha 2009-07-10 10:39:17 UTC
Config:
Product Version: NetBeans IDE Dev (Build 090710)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02
System: Linux version 2.6.28-13-generic running on amd64; UTF-8; en_US (nb)

Steps:
1) create new maven project with QuickStart archetype.
Comment 1 Petr Blaha 2009-07-10 10:39:47 UTC
Created attachment 84583 [details]
thread dump
Comment 2 Jan Jancura 2009-07-10 15:24:01 UTC
=> Java Source
Comment 3 David Strupl 2009-07-13 09:15:20 UTC
Vita or Dusan please have a look ...
Comment 4 Vitezslav Stejskal 2009-07-14 10:27:06 UTC
I have an idea how this could be fixed, but will first attach the patch here and ask for review.
Comment 5 Vitezslav Stejskal 2009-07-14 10:41:22 UTC
Created attachment 84694 [details]
Proposed patch - please review
Comment 6 Vitezslav Stejskal 2009-07-14 11:34:37 UTC
Btw. I wasn't able to reproduce the problem, which is of course not that surprising for a threading problem.
Comment 7 Tomas Zezula 2009-07-15 18:02:02 UTC
Fixed in a bit different way.
Integrsted into jet-main: http://hg.netbeans.org/jet-main/rev/b8ab3f2a1640
Comment 8 Quality Engineering 2009-07-16 06:00:21 UTC
Integrated into 'main-golden', will be available in build *200907160201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b8ab3f2a1640
User: Tomas Zezula <tzezula@netbeans.org>
Log: #168388:Deadlock in ClassIndexManager
Comment 9 Marian Mirilovic 2009-07-16 07:51:30 UTC
*** Issue 168635 has been marked as a duplicate of this issue. ***
Comment 10 pgebauer 2009-07-16 09:54:04 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/912bf0dba5ba
Comment 11 Petr Blaha 2009-07-16 10:00:25 UTC
I tested the maven web/j2se and ear project in the latest build and can't reproduce. It seems as fixed.
Comment 12 Marian Mirilovic 2009-07-16 15:59:36 UTC
*** Issue 167613 has been marked as a duplicate of this issue. ***
Comment 13 Jiri Prox 2009-07-16 17:23:55 UTC
I cannot reproduce it in 6.7.1 as well
Comment 14 David Strupl 2009-07-30 13:30:55 UTC
*** Issue 168885 has been marked as a duplicate of this issue. ***
Comment 15 David Strupl 2009-10-19 14:26:16 UTC
*** Issue 167645 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo