Bug 168350 - syntax error higlighing underlines only last line
syntax error higlighing underlines only last line
Status: RESOLVED DUPLICATE of bug 211165
Product: php
Classification: Unclassified
Component: Code
6.x
All All
: P3 with 2 votes (vote)
: 7.2
Assigned To: Ondrej Brejla
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 15:45 UTC by Filip Zamboj
Modified: 2012-04-27 09:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Zamboj 2009-07-09 15:45:12 UTC
Product Version: NetBeans IDE Dev (Build 200907090200)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02

consider this code where NB 65 underlines lines 4,6,7,8 and NB 68 underlines 8 only. It's more difficult to find a
syntax error in longer code. 
1 <body>
2         <?php
3        class a extends 
4        {
5            
6            public $a, $b;
7            protected $c, $d;
8            private $e, $f; //NB 68 underlines this line only 
9        }
        
        ?>
    </body>
Comment 1 floatinglute 2009-08-16 10:57:15 UTC
Same here. In my case I noticed it with missing semicolon not producing syntax error highlighting.

NetBeans IDE Dev (Build 200908022240), Java-Sun 1.6.0_15, x86_64 OpenSuse 11.1
Comment 2 Filip Zamboj 2010-09-15 12:29:24 UTC
batch reassigning
Comment 3 OndrejBrejla 2011-02-11 15:20:44 UTC
I can reproduce it.
Comment 4 JohnnyWalker2001 2011-04-18 12:39:49 UTC
Connected to: http://netbeans.org/bugzilla/show_bug.cgi?id=197756 ?
Comment 5 Tomas Mysik 2011-06-03 10:18:27 UTC
Batch reassigning.
Comment 6 Tomas Mysik 2011-06-08 08:57:34 UTC
Editor area.
Comment 7 Petr Pisl 2011-09-23 13:57:01 UTC
Error handling needs to be improved.
Comment 8 Ondrej Brejla 2012-04-27 09:32:59 UTC

*** This bug has been marked as a duplicate of bug 211165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo