Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168309 - [67cat] NullPointerException at sun.swing.table.DefaultTableCellHeaderRenderer.getColumnSortOrder
[67cat] NullPointerException at sun.swing.table.DefaultTableCellHeaderRendere...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Action Items
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
tasklist-issues@contrib
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
:
: 165999 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 01:30 UTC by brettryan
Modified: 2009-08-02 14:50 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.49 KB, text/plain)
2009-07-09 01:30 UTC, brettryan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description brettryan 2009-07-09 01:30:16 UTC
This issue was originally marked as duplicate of issue 143964, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE 6.7 (Build 200906241340)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows Vista, 6.0, x86

User Comments:
GUEST: Changing  my windows font settings turning off ClearType.

GUEST: Opening a C++ project. Also occors when I unfold/collaps the tree. Only resolts I can see are that it sometimes leaves a big gap between projects.

GUEST: Opening a C++ project. Also occors when I unfold/collaps the tree. Only resolts I can see are that it sometimes leaves a big gap between projects.

GUEST: i was basically doing nothing... NB was just opened, and i hadn't started working yet

my current project opens with NB of course

GUEST: NB wam minimized. When restored I could not use backspace button and the red icon was flashing on the right bottom corner. I couls type character but coul not delete any.

GUEST: Running a JavaScript project from NetBeans on Glassfish.

GUEST: Downloading JavaFX plugins

GUEST: Start Windows magnifier, which opened at the top of the screen and resized NetBeans window.

GUEST: I'm not sure.  I was not actively using NetBeans when the error occurred.

GUEST: I was making a bot, I made it write Hello!, but the exclamation mark made an error, I'm not sure it's that, 'cause I noticed it right now xD...

GUEST: asdf

GUEST: Apenas mandei criar um novo projeto web.

t3q: Can't provide details

GUEST: Ran Java console app

GUEST: solo observando el codigo

GUEST: Machine was in screensaver mode

GUEST: nada solo observando

GUEST: The program was idle I beleve

GUEST: remote desktop to windows to use netbeans. the arrow key and backspace dose not work. 
but other key like a-z 1-0 all worked.

GUEST: starting glassfish

GUEST: I was changing windows color scheme, when NetBeans was scanning the projects.

GUEST: Logged in to remote desktop session.

GUEST: I was using Windows Remote Desktop... I closed my session... and reopened it after a while. When I reopened it I got this error.

brettryan: Logged in via RDC to an existing instance of NB.

GUEST: Ejecutando una tarea ant

brettryan: Every time I hit cancel error keeps coming back, need to force quit NB.

delrieu: on a java code window:
- cannot scroll down
- 'end' key not functional

GUEST: C:\Users\khobeib\Documents\NetBeansProjects\WebApplication1\nbproject\build-impl.xml:558: Deployment error:
The Sun Java System Application Server could not start.
More information about the cause is in the Server log file.
Possible reasons include:
 - IDE timeout: refresh the server node to see if it's running now.
 - Port conflicts. (use netstat -a to detect possible port numbers already used by the operating system.) 
 - Incorrect server configuration (domain.xml to be corrected manually) 
 - Corrupted Deployed Applications preventing the server to start.(This can be seen in the server.log file. In this case, domain.xml needs to be modified).
 - Invalid installation location.
See the server log for details.
BUILD FAILED (total time: 33 seconds)

GUEST: Backspace doesn't work anymore

GUEST: svn show changes

GUEST: Resuming a disconnected remote session.

GUEST: -------------------------------------------------------------------------------
>Log Session: Friday, June 19, 2009 9:38:52 AM JST
>System Info: 
  Product Version         = NetBeans IDE 6.7 RC2 (Build 200906042131)
  Operating System        = Windows Vista version 6.0 running on x86
  Java; VM; Vendor        = 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02; Sun Microsystems Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_13-b03
  Java Home               = C:\Java\jdk1.6.0_13\jre
  System Locale; Encoding = ja_JP (nb); MS932
  Home Directory          = C:\Users\A13667
  Current Directory       = C:\Program Files\NetBeans 6.7 RC2
  User Directory          = C:\Users\A13667\.netbeans\6.7rc2
  Installation            = C:\Program Files\NetBeans 6.7 RC2\nb6.7
                            C:\Program Files\NetBeans 6.7 RC2\ergonomics1
                            C:\Program Files\NetBeans 6.7 RC2\ide11
                            C:\Program Files\NetBeans 6.7 RC2\java2

GUEST: SVN Update

ijay: Keep NB opening for a whole night and this bug appears

GUEST: indexing repository

GUEST: RemoteDesktop connection was terminated

GUEST: open a web.xml file

GUEST: minimizing/maximizing windows.

GUEST: minimizing/maximizing windows.

GUEST: minimizing/maximizing windows.

GUEST: minimazing/maximizing window.

GUEST: Just started NetBeans: it opens the Swing file in Design mode on startup (as was there when I closed NB).
Then the app sat like that for 1min and when I switched back to it I found the error.
Nothing else.

GUEST: logged in to remote machine running netbeans 6.7  via remote desktop on Windows 7 RC

GUEST: I was editing code OUTSIDE of my swing-using class. This seems to keep occurring when compiling on-the-fly when some elements of the project are Swing.

codeamatic: Nothing.  I simply just came back to netbeans after having left my computer idle for a few hours with Netbeans open

GUEST: expanding folder in "project view"

brettryan: I think this is due to using NB while connecting to a remote desktop session while NB is already running.

Steps to reproduce.
1. Start NB on a Vista machine.
2. Start netbeans and open a project.
3. On an XP machine open a microsoft RDC connection to the Vista machine.
4. Start using the already running NB instance.

-- Expected behaviour
You should experience lots of NPE's and parts of the UI will be missing.

GUEST: Just moving to a source file; however, the window is scrunched to only half of the screen because I am watching a movie in another window that takes up the other half of the screen.

GUEST: I clicked in the editor.

GUEST: Disabled secondary monitor and aero

GUEST: browsing some internet pages

jonast: did it in the background while I was doing other things

GUEST: I woke up this morning and the Exceotion was there when I turned on the screen. The Netbeans window has been idle for maby a little over 24 hours.

GUEST: Trying to set a breakpoint, Netbeans is Breaking!!! All the time!!! Even on a fresh minimal install. What gives? When I do get a breakpoint set, and I try to go to its properties, I literally get an empty window...no customization options are there. Its like a properly sized JDialog with no components!

GUEST: The IDE is on the back ground idle for a period of time when I noticed the red alert flashing.

GUEST: Editing program

GUEST: Nothing

GUEST: Subversion

GUEST: subversion

GUEST: subversion

GUEST: subversion

GUEST: subversion

GUEST: Had just started NetBeans...

GUEST: Editing source code, then I minimize NetBean and Open Mozilla Firefox, when I return to NetBeans IDE, this message was showed.

GUEST: Creating a progeam

GUEST: Just scrolling up and down in the code

GUEST: Computer was asleep. When up and running again, I saw the red icon on th bottom right of the status bar.

GUEST: -starting the svn import dialog, cancel the dialog because subversion was not installed
-compiling and running the project i am working on
-creating a new class

These were the actions I am aware of. Sorry can�t be more specific.
Thanks!

GUEST: ...and again

GUEST: This error appears always while trying to run Update on a project from CVS.

GUEST: Arrow keys don't work after connecting through Remote Desktop.

lostmats: logged in via rdp (mstsc)

lostmats: logged in via rdp (mstsc)

lostmats: logged in via rdp (mstsc)



Stacktrace: 
java.lang.NullPointerException
        at sun.swing.table.DefaultTableCellHeaderRenderer.getColumnSortOrder(DefaultTableCellHeaderRenderer.java:114)
        at com.sun.java.swing.plaf.windows.WindowsTableHeaderUI$XPDefaultRenderer.getTableCellRendererComponent(WindowsTableHeaderUI.java:108)
        at org.netbeans.modules.tasklist.ui.TaskListTable$SortingHeaderRenderer.getTableCellRendererComponent(TaskListTable.java:702)
        at javax.swing.plaf.basic.BasicTableHeaderUI.getHeaderRenderer(BasicTableHeaderUI.java:663)
        at javax.swing.plaf.basic.BasicTableHeaderUI.getHeaderHeight(BasicTableHeaderUI.java:698)
        at javax.swing.plaf.basic.BasicTableHeaderUI.createHeaderSize(BasicTableHeaderUI.java:727)
Comment 1 brettryan 2009-07-09 01:30:33 UTC
Created attachment 84517 [details]
stacktrace
Comment 2 Marian Mirilovic 2009-07-09 09:36:22 UTC
448 duplicates ... P1 ... NB 6.7 Patch candidate (very probably not Patch 1)
Comment 3 Stanislav Aubrecht 2009-07-09 10:38:06 UTC
fixed

core-main 447df64df85e

btw, i went through jdk sources and it seems that upgrade to jdk1.6_u14 should fix this problem in older versions of
netbeans
Comment 4 Marian Mirilovic 2009-07-09 16:37:02 UTC
v.
Comment 5 Quality Engineering 2009-07-10 05:42:23 UTC
Integrated into 'main-golden', will be available in build *200907100200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/447df64df85e
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #168309 - NPE
Comment 6 pgebauer 2009-07-10 09:40:54 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/b02a97ae5811
Comment 7 Stanislav Aubrecht 2009-07-15 09:57:26 UTC
*** Issue 165999 has been marked as a duplicate of this issue. ***
Comment 8 Marian Mirilovic 2009-07-16 16:24:30 UTC
last report is from the IDE before the fix was integrated - verified in patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo