Bug 16814 - Unable to stop the XML validation process when using a large XML document.
Unable to stop the XML validation process when using a large XML document.
Status: CLOSED FIXED
Product: xml
Classification: Unclassified
Component: Code
3.x
All Other
: P1 (vote)
: 3.x
Assigned To: issues@xml
issues@xml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 10:50 UTC by issues@www
Modified: 2005-03-09 04:28 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description issues@www 2001-10-22 10:50:38 UTC
Description: 
File: http://javaweb/~xxx/assertions/EJBAssertions.xml
http://javaweb/~xxx/assertions/assertions.dtd

When validating this large file, it is impossible to stop the validation
(validate XML). It's take more than 10 minutes to the IDE to complete the task.
A right mouse button must be available to stop the process.

Thanks,

-- Jeanfrancois


Evaluation: 
There could be property, which describes number errors display in Output window
and Validate action will be terminated.

---

In my experience validation is slow vhen you have open Text Editor
and document contains a lot of errors. That is probably due lot of
outputs in to Output window.

Solution:

Stop validation after several (e.g. 20) errors occur.

-- mschovanek

There could be property, which describes number errors display in Output window 
and Validate action will be terminated.

-- lk
A comment.
Comment 1 _ pkuzel 2001-10-24 10:39:49 UTC
The validation is asynchronous process, and  there is currently no way
how to stop it. So I implemented error limit (20) that stops parser
from further processing an input document. It virtually eliminates the
problem as the major slow down is caused by writing message into
output window.
Comment 2 Martin Schovanek 2001-11-16 10:11:01 UTC
Verified.
Comment 3 Quality Engineering 2003-07-02 08:38:16 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo