Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167904 - Did not see a option to Import Cerificates into Jave ME SDK 3.0 embedded in NB6.7
Did not see a option to Import Cerificates into Jave ME SDK 3.0 embedded in N...
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Build System
6.x
All Windows Vista
: P1 (vote)
: 6.x
Assigned To: Petr Suchomel
issues@mobility
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 16:15 UTC by kmusham
Modified: 2009-07-31 23:33 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kmusham 2009-06-30 16:17:30 UTC
I just installed Netbeans 6.7 IDE. I am running my J2ME application using the default CLDC emulator which comes along 
with the IDE. My application is failed to make HTTP Connection. I realized that I have to add my propritery 
certificate as I always do with other emulators (WTK 2.5.1  and Sprint WTK). Can you please tell me how to add or 
import certificates into Java ME SDK 3.0 version. Please note that this emulator is not istalled as a standalone 
application, it is part of Netbeans 6.7. 

Unfortunately I did not see any option to add/import certificates. Please help me.

Thanks
Kiran
Comment 1 Petr Suchomel 2009-07-01 14:04:19 UTC
Yes, the export into Java ME SDK 3.0 does not work. The workaround is to use NetBeans
6.7\mobility8\Java_ME_platform_SDK_3.0\bin\mekeytool.exe for exporting the certificates
Comment 2 kmusham 2009-07-02 15:24:39 UTC
It would be nice if you can provide a UI to do the same like on Netbeans 6.5 and older.

I have played with mekeytool.exe and it is so complex to provide the arguments. I did not had time to pplay more.

So as a short cut, I have copied main.mks file from WTK and copied in the 3.0 SDK emulator folder and renamed to 
_main.ks. It works now.
But I would have spend lot of time to resolt it.

Please provide us UI to do the same. Otherwise I did not see any value of having SDK 3.0.

Regards
Kiran
Comment 3 Petr Suchomel 2009-07-02 15:31:41 UTC
Under work now. Should be available soon.
Comment 4 Marian Mirilovic 2009-07-09 08:32:18 UTC
What is the status of this issue ? In case we want to fix it into NB 6.7.1 it's 5 minutes after twelve ....
Comment 5 Petr Suchomel 2009-07-09 11:09:09 UTC
Fixed in CS 7db77b437dc2
Comment 6 Petr Suchomel 2009-07-13 17:55:05 UTC
Lucky with Hg, next try 0da43140cc35
Comment 7 Quality Engineering 2009-07-14 06:24:04 UTC
Integrated into 'main-golden', will be available in build *200907140201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0da43140cc35
User: psuchomel@netbeans.org
Log: Fix for #167904, Support for importing Cerificates into Jave ME SDK 3.0
Comment 8 Andrei Chistiakov 2009-07-14 11:51:28 UTC
Verified with NetBeans IDE Dev (Build 200907140201)
Comment 9 pgebauer 2009-07-14 12:04:51 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/dc777800cec1

Note: The changeset 0da43140cc35 has been ported only. If the changeset 7db77b437dc2 is needed as well, please specify valid repository.
Comment 10 Andrei Chistiakov 2009-07-20 12:09:33 UTC
Verified with NetBeans IDE 6.7.1 (Build 200907192301) FCS.
Comment 11 kmusham 2009-07-28 17:20:06 UTC
I am sorry, but I still did not see a option to do in in 6.7.1 release.
Please explain me your fix and send me a document or steps to install certificates.

I was expecting to enable Project Properties->Mananage Emulators->Tools & Extensions->Open Utilities
or something similar where you can import certificates with simple User interface.

I would also want to see other options like "Open Preferences" is enabled.

Thanks.
Comment 12 Andrei Chistiakov 2009-07-29 11:46:42 UTC
kmusham,
Could you please take a look at Tools->Keystores->Export button from main menu or at project Properties->Signing
category->Export Key into Java ME SDK... button? Is that what you would like to use?
Comment 13 Andrei Chistiakov 2009-07-29 14:52:21 UTC
Marking this issue as INCOMPLETE - waiting for respose from submitter.
Comment 14 kmusham 2009-07-31 17:15:31 UTC
I saw the option Keystores under tools. 
I did not expect in this way but any way, we have some option in the IDE to do.

Please close the bug.
Comment 15 Andrei Chistiakov 2009-07-31 23:32:22 UTC
OK, thanks for the response.
Comment 16 Andrei Chistiakov 2009-07-31 23:33:11 UTC
The issue is fixed/verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo