Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167865 - [NB 6.7] Palette items have '&' typo at the end
[NB 6.7] Palette items have '&' typo at the end
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Unsupported
6.x
All All
: P2 (vote)
: TBD
Assigned To: Anton Chechel
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 10:25 UTC by Alexandr Scherbatiy
Modified: 2009-07-21 10:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2009-06-30 10:25:39 UTC
marina-netbeans-plugin ยป #188

  Product Version         = NetBeans IDE 6.7 (Build 200906212001)
  Operating System        = Mac OS X version 10.5.6 running on i386
  Java; VM; Vendor        = 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133; Apple Inc.


Steps to reproduce:

- Drag and drop Stage component from the palette to the editor
----------------------------------------
import javafx.stage.Stage;
import javafx.scene.Scene;

Stage {
        title : "MyApp"
        scene: Scene {
                width: 200
                height: 200
                content: [  ]
        }
}
&
----------------------------------------
It has '&' symbol at the end

It is also reproduced fro other components
Comment 1 Alexandr Scherbatiy 2009-07-13 13:41:23 UTC
It also reproduces on Solaris and Windows XP.
Comment 2 Anton Chechel 2009-07-16 15:19:23 UTC
fixed
Comment 3 Alexandr Scherbatiy 2009-07-20 10:08:28 UTC
marina-netbeans-plugin: #211

It seems that the issue is reproduced for all palette items in the latest build:
-----------------------------------------------------------------------
Stage {
         title : "MyApp"
         scene: Scene {
                 width: 200
                 height: 200
                 content: [  ]
         }
 }&
-----------------------------------------------------------------------
 Scene {
         content: [  ]
 }&
-----------------------------------------------------------------------
 Blend {
         mode: BlendMode.ADD
         opacity : 0.5
 }&
----------------------------------------------------------------------- 
 Media {
         source : ""
 }&
-----------------------------------------------------------------------
Comment 4 Anton Chechel 2009-07-20 10:39:28 UTC
It works for me and I also checked it on different machine. Please check whether you have latest build and that build
includes latest mercurial changes.
Comment 5 Alexandr Scherbatiy 2009-07-20 11:07:47 UTC
I use installers from marina-netbeans-plugin build: #211
  marina-netbeans-plugin/211/artifact/build/installers/

The issue is reproduced on Windows, Mac and Solaris.

The build #203 should already contain the fix:

 Build #203 (Jul 17, 2009 3:47:26 AM)
	Changes

   1. #168529 - fix for handling jar files on compile class path (detail)
   2. issue #168418 has been fixed (detail)
   3. issue #167949 has been fixed (detail)
   4. issue #1167865 has been fixed (detail)
   5. issue #167972 has been fixed (detail)
   6. manual merge (detail)
   7. #168545 - GoToSource from profiler works only for "SOURCES" classpath (detail)


Comment 6 Alexandr Scherbatiy 2009-07-20 11:53:14 UTC
The issue is also reproduced in NetBeans 6.7.1 fcs installer:
http://smetiste.czech.sun.com/builds/netbeans/6.7.1/fcs/2009-07-19_23-01-10/

I tried All bundle.
Comment 7 Anton Chechel 2009-07-20 15:30:41 UTC
fixed
PS: Notice what there is bug in template engine http://www.netbeans.org/issues/show_bug.cgi?id=168820
If you will d'n'd item from palette to completely empty document, that bug appears before indentation.
Comment 8 Alexandr Scherbatiy 2009-07-21 10:09:55 UTC
verified in NetBeans 6.7.1 fcs 2009-07-20_23-01-10


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo