Bug 16783 - Manually downloaded modules won't install
Manually downloaded modules won't install
Status: CLOSED INVALID
Product: db
Classification: Unclassified
Component: Code
3.x
PC Windows 3.1/NT
: P3 (vote)
: 3.x
Assigned To: akemr
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-19 16:48 UTC by ats37
Modified: 2003-06-30 17:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ats37 2001-10-19 16:48:37 UTC
I can't persuade the AutoUpdate to get past our firewall, so I'm trying to 
install some downloaded .nbm modules (db.nbm and junit.nbm)

On the first wizard page, I select to Install Manually Downloaded Modules.
On the second page, I select the two .nbm files.
However, when I click the Next button, "To have the Update Center check digital 
signatures", I just get an empty page titled "Select Modules to Install" and 
the steps indicator on the left still shows step 2 in bold.  Nothing is listed 
in the "Available Updates and New Modules" box and the Next button is 
disabled.  My only options are to go Back, or Cancel.

I'm using version 3.2.1 Build 98.
Comment 1 ats37 2001-10-19 17:01:23 UTC
I also tried installing the modules from the Tools->Options window, 
by right-clicking on the Modules node and selecting New->Module from 
NBM file...  However, after selecting the module in the file 
requestor, I get the same empty "Select Modules to Install" page 
displayed.
Comment 2 akemr 2001-10-22 08:07:13 UTC
Strange, I cannot reproduce it. This situation (empty Selected 
modules list) should appear, when spec. version of nbm is <= spec.
version of currently installed module..

So I have more questions:

- Do you have previous versions of these modules installed?
  If yes, what are current spec. versions?
- Do you have read priviledges from nbm's directory?
- Where did you get these nbm's?
- What are spec. versions of these nbm's? You can find them in nbm, 
in Info/info.xml

Thanks.
Comment 3 ats37 2001-10-23 13:45:14 UTC
>- Do you have previous versions of these modules installed?
>  If yes, what are current spec. versions?

It looks like the junit one has been (there's a junit.jar in the 
modules directory the same file size as the one in the nbm).  I think 
I was just looking in the wrong place for it in the modules list.  
Perhaps the Update screen ought to list all the chosen modules, but 
not let you install any that aren't a newer version?  Less confusing 
than an empty list, since at least then you'd know why they won't 
install.

However, as for db.nbm, there's no sign of its jars anywhere on my 
system.  Plus I only noticed the contrib@netbeans.org message about 
it last week, and as that's more recent than the 3.2.1 release 
announcement, I'd be surprised if it had already been in that release.

>- Do you have read priviledges from nbm's directory?

Yes, it's on the local hard drive and I have full access rights.  I 
can read/extract it myself with jar, without any problem.

- Where did you get these nbm's?

From the attachment to the announcement message at 
http://www.netbeans.org/servlets/ReadMsg?msgId=145847&listName=contrib
The module's download page at 
http://db.netbeans.org/servlets/ProjectDownloadList doesn't have any 
files available yet.

- What are spec. versions of these nbm's? You can find them in nbm, 
in Info/info.xml

Is this the bit you need?

  <manifest OpenIDE-Module-
Install="org/netbeans/modules/db/DatabaseModule.class"
            OpenIDE-Module-Name="Database Explorer"
            OpenIDE-Module-Short-Description="Views and modifies the 
structure of the connected database."
            OpenIDE-Module-Long-Description="Uses the Explorer to 
view the current structure of the connected database tables and their 
data while you are developing database applications or applets within 
the IDE."
            OpenIDE-Module-Implementation-Version="dev-000"
            Class-Path="docs/db.jar"
            OpenIDE-Module-Specification-Version="1.4"
            OpenIDE-Module-Display-Category="Database"
            OpenIDE-Module="org.netbeans.modules.db/1"
            OpenIDE-Module-
Description="org.netbeans.modules.db.docs.HelpSet"
  />
Comment 4 akemr 2001-10-23 14:06:27 UTC
OK, I tried it and discover that this db.nbm is not valid. So I 
suggest to download in using AU wizard (and set proxy in first step).

CCing Radko - DB module owner
Comment 5 ats37 2001-10-23 17:59:57 UTC
Unfortunately, and as I said in the first place, "I can't persuade 
the AutoUpdate to get past our firewall".  I've got the proxy host 
and port configured with the same settings that are used by the web 
browser, but it still won't connect.  I just get repeatedly prompted 
for a user name and password - I get the same with other software, 
though.  I think the proxy's smart (and locked down) enough to not 
allow anything else through - I entered the autoupdate URL into IE 
once, and it fetched it with no trouble.

So, I guess I'll just have to wait and hope for a valid nbm to appear 
on the module's web pages.
Comment 6 Radko Najman 2001-10-24 08:47:34 UTC
Component changed from autoupdate to db.
Comment 7 Radko Najman 2001-10-24 17:20:55 UTC
Database Explorer .nbm file were added on the module's web pages. It can be downloaded from 
http://db.netbeans.org/servlets/ProjectDownloadList
Comment 8 Martin Schovanek 2003-03-12 14:13:11 UTC
VERIFIED
Comment 9 Quality Engineering 2003-06-30 17:17:53 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo