Bug 167786 - Fails to Startup
Fails to Startup
Status: RESOLVED INVALID
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
PC All
: P3 (vote)
: 6.x
Assigned To: Jan Jancura
issues@editor
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 10:36 UTC by neilyboy
Modified: 2009-09-21 13:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Messages log for netbeans failing to start (34.92 KB, text/plain)
2009-06-29 10:39 UTC, neilyboy
Details
Thread dump created a point where NB freezes (20.56 KB, text/plain)
2009-06-29 15:10 UTC, neilyboy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description neilyboy 2009-06-29 10:36:43 UTC
Running NB6.7RC1 on windows XP. 
Fails to start, splash screen appears and gets to "Done loading modules" and main window starts to appear but only shows
title bar. No activity in process monitor/task manager. Clicking close is ignored, process needs killed.

Renaming the profile folder will make it start, ie if i change
.netbeans\6.7rc1 changed to .netbeans\6.7rc1-OLD then it picks up the old profile from .netbeans\6.5 and loads. However
all my setting, modules plugins from 6.7 are lost.

I will attach the messages.log
Comment 1 neilyboy 2009-06-29 10:39:58 UTC
Created attachment 84123 [details]
Messages log for netbeans failing to start
Comment 2 Oleg Khokhlov 2009-06-29 12:09:06 UTC
neilyboy, 
could you please try newest build?
Comment 3 t_h 2009-06-29 12:11:42 UTC
Can you make a thread dump?
Comment 4 neilyboy 2009-06-29 15:09:32 UTC
Ok, tried both suggestions.
Good news, latest build 200906261401 does not have the problem. On first run it wanted to import settings from
.netbeans\6.5 instead of .netbeans\6.7rc1 so canceled and renamed the old profile directory from .netbeans\6.7rc1 to
.netbeans\dev
The new build picked up this as its profile directory and ran no problem., all of my 

So it looks ok now, although the new build does complain of system slowness.

For interest I will attach the thread dump. 
Also i noticed running the build with the problem just before it hangs it tries to access the floppy drive (i hear it
clunk), maybe a co-incidence...?
Comment 5 neilyboy 2009-06-29 15:10:55 UTC
Created attachment 84139 [details]
Thread dump created a point where NB freezes
Comment 6 neilyboy 2009-06-30 09:41:16 UTC
Unfortunatly this problem is now occuring with the latest built aswell.

In the latest build I installed the visual JSF and visual JSF runtime, once installed the dialog telling me that install
was complete did not respond.

So i had to Kill the NB process, on startup the latest build is now behaving as i reported the RC1 to be behaving,
freezing on startup.
Comment 7 Vitezslav Stejskal 2009-08-13 09:22:36 UTC
Could you please attach threaddump from the latest dev build (assuming its still a problem in the latest dev build)? Thanks
Comment 8 Jiri Prox 2009-09-21 13:48:06 UTC
Without requested information for long time - INVALID. We can't do anything in this case. Reporter, please add requested
information and reopen issue. Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo