Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167479 - Problems with the output window (always stacks, minimum of 2, output doesn't stay)
Problems with the output window (always stacks, minimum of 2, output doesn't ...
Status: RESOLVED DUPLICATE of bug 167480
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
PC Windows 7 x64
: P3 (vote)
: 6.x
Assigned To: Thomas Preisler
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 19:29 UTC by karmaflute
Modified: 2009-06-24 15:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Exit dialogue (20.91 KB, text/plain)
2009-06-22 20:07 UTC, karmaflute
Details
Corrected MIME type (20.91 KB, image/png)
2009-06-22 20:51 UTC, karmaflute
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karmaflute 2009-06-22 19:29:23 UTC
This bug is for NetBeans 6.7RC3.

When running my C++ project Netbeans always creates a new output window and stacks it on top of the old ones. It doesn't
attempt to reuse an existing output window. So, if I compile 20 times I get 20 output tabs I have to close by hand.

Even if I close all of the output windows if I try to compile there is always a minimum of 2 tabs created; one for the
current output and another tab for the last project I compiled (even though I already closed the window).

The output window is also clears itself after the program runs (output begins to fill with text then goes completely blank).

Output is completely broken for C++.
Comment 1 Leonid Lenyashin 2009-06-22 19:35:14 UTC
Thank you for reporting, however it does not fit our P1 criterion. It is a regular P3, which does not mean it won't be
addressed quickly.

Thomas, can you please take a look.
Comment 2 karmaflute 2009-06-22 19:37:34 UTC
I've corrected the bug report to identify that I'm using Win7 x64.

Thank you for the clarification. Where can I find a list of what you consider to be relevant to each priority level?
Comment 3 karmaflute 2009-06-22 20:07:30 UTC
Created attachment 83888 [details]
Exit dialogue
Comment 4 karmaflute 2009-06-22 20:08:53 UTC
When I tried to close the IDE it said that the applications are still running. I checked the task manager and I have a
ton of cmd.exe programs running but there is no console "window" on the desktop.
Comment 5 karmaflute 2009-06-22 20:09:53 UTC
This may be related to my other bug here:

http://www.netbeans.org/issues/show_bug.cgi?id=167480
Comment 6 Leonid Lenyashin 2009-06-22 20:20:49 UTC
Priority guidelines are right here: http://wiki.netbeans.org/BugPriorityGuidelines. You do not have to be an expert in
our guidelines, you can simply rely on me.
I'm not sure what you are trying to achieve playing with priorities? It is not a vehicle to influence development team.
If you want support yourself with defined SLA we have some offering of support contracts. If you are just trying to help
community reporting an issue that you think is important, then this is very welcomed and there is really no need to play
priorities game. It will not help community, it will not help you.
If you are so eager to have it fixed immediately you can join us and fix it yourself. It will be great help and will be
really appreciated by everybody. It is open source world and here are some rules...

Again, thank you for reporting and we will address your issue is P3.
Comment 7 Leonid Lenyashin 2009-06-22 20:22:05 UTC
I'm sorry you have created an attachment with wrong mime-type. Could you please resubmit it with a correct one.
Comment 8 karmaflute 2009-06-22 20:51:43 UTC
Created attachment 83889 [details]
Corrected MIME type
Comment 9 Vladimir Voskresensky 2009-06-22 22:25:40 UTC
output is reused if previous process released it. in case of never ending application new tab is created on each "run"
Comment 10 Thomas Preisler 2009-06-23 07:20:51 UTC
First off, this is not the behavior I see on Windows Vista. Something is obviously wrong in your case, perhaps some Windows 7 issue. Here are a couple of 
things you can try:

1) Try a simple Welcome project (from C/C++ samples). Does that work better? You may need to restart IDE first.

2) Try to turn off profiling. Open project properties and click on Profile category. Unselect Profile On Run. Do you see any change in behavior?

3) Try to use internal output window. Open project properties and select Run category. Select Output Window in Console Type. Any change in behavior?
Comment 11 Thomas Preisler 2009-06-23 08:50:35 UTC
Problems like related to other issue. Can you please try and create a Welcome project outside your normal user directory so path doesn't contain the "'" 
character. Als, if you could try a different installation location for NetBeans?
Comment 12 Thomas Preisler 2009-06-24 15:37:55 UTC
Very likely same root problems as 167480  Cannot compile with MinGW. Will close as dup.

*** This issue has been marked as a duplicate of 167480 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo