Bug 167444 - Deadlock while attaching debugger
Deadlock while attaching debugger
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
PC Windows Vista
: P2 (vote)
: 6.x
Assigned To: Daniel Prusa
issues@debugger
:
: 167584 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 09:16 UTC by Jiri Skrivanek
Modified: 2009-06-25 09:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump. (23.59 KB, text/plain)
2009-06-22 09:19 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2009-06-22 09:16:24 UTC
There seem to be a deadlock while attaching debugger. To reproduce:

- open Window>Debugging>Variables
- run Debug>Attach Debugger...
- fill desired parameter in the dialog and click OK
- it freezes (see attached thread dump)

Product Version: NetBeans IDE Dev (Build 200906211401)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows Vista version 6.0 running on x86; Cp1250; cs_CZ (nb)
Comment 1 Jiri Skrivanek 2009-06-22 09:19:15 UTC
Created attachment 83864 [details]
Thread dump.
Comment 2 Daniel Prusa 2009-06-22 10:55:07 UTC
Some synchronization problem in code evaluator.
Comment 3 Daniel Prusa 2009-06-23 14:29:54 UTC
Fixed.
http://hg.netbeans.org/main/rev/cef6f08043da
Comment 4 Quality Engineering 2009-06-24 07:29:50 UTC
Integrated into 'main-golden', will be available in build *200906240201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cef6f08043da
User: Daniel Prusa <dprusa@netbeans.org>
Log: #167444: Deadlock while attaching debugger
Comment 5 Jiri Skrivanek 2009-06-24 09:27:34 UTC
Verified.
Comment 6 Daniel Prusa 2009-06-24 22:45:43 UTC
*** Issue 167584 has been marked as a duplicate of this issue. ***
Comment 7 Martin Entlicher 2009-06-25 09:34:11 UTC
Since this issue is in 6.8 builds only, it can not be a candidate for 6.7.
This issue was caused by fix of issue #166020, which is not planed to be ported to 6.7.
Comment 8 Vojtech Sigler 2009-06-25 09:42:38 UTC
Oh, I'm sorry, I missed it was reported for 6.8, thought it was still for 6.7. :)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo