Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166817 - NullPointerException at org.netbeans.modules.web.core.syntax.JSPProcessor.getImportsFromJspParser
NullPointerException at org.netbeans.modules.web.core.syntax.JSPProcessor.get...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSP
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomasz Slota
issues@javaee
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 22:48 UTC by mjreged
Modified: 2009-07-23 13:48 UTC (History)
12 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.36 KB, text/plain)
2009-06-09 22:48 UTC, mjreged
Details
stacktrace (1.36 KB, text/plain)
2009-06-12 15:48 UTC, rdelaplante
Details
stacktrace (1.36 KB, text/plain)
2009-06-12 15:49 UTC, rdelaplante
Details
stacktrace (1.36 KB, text/plain)
2009-06-12 15:51 UTC, rdelaplante
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mjreged 2009-06-09 22:48:34 UTC
Build: NetBeans IDE 6.7 RC2 (Build 200906042131)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP, 5.1, x86

User Comments:
mjreged: While navigating facelets and jsp files

GUEST: editing javascript

GUEST: editing facelet page



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.web.core.syntax.JSPProcessor.getImportsFromJspParser(JSPProcessor.java:319)
        at org.netbeans.modules.web.core.syntax.JSPProcessor.createImplicitImportStatements(JSPProcessor.java:295)
        at org.netbeans.modules.web.core.syntax.SimplifiedJspServlet.renderProcess(SimplifiedJspServlet.java:201)
        at org.netbeans.modules.web.core.syntax.JSPProcessor$2.run(JSPProcessor.java:272)
        at org.netbeans.editor.BaseDocument.render(BaseDocument.java:1371)
        at org.netbeans.modules.web.core.syntax.JSPProcessor.process(JSPProcessor.java:268)
Comment 1 mjreged 2009-06-09 22:48:39 UTC
Created attachment 83369 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-06-09 22:48:44 UTC
This issue already has 12 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=151988
Comment 3 Exceptions Reporter 2009-06-11 01:08:54 UTC
This issue already has 14 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=151988
Comment 4 rdelaplante 2009-06-12 15:48:22 UTC
Build: NetBeans IDE 6.7 RC2 (Build 200906042131)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: SunOS, 5.11, x86

User Comments: 
Editing facelets .xhtml pages?

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.web.core.syntax.JSPProcessor.getImportsFromJspParser(JSPProcessor.java:319)
        at org.netbeans.modules.web.core.syntax.JSPProcessor.createImplicitImportStatements(JSPProcessor.java:295)
        at org.netbeans.modules.web.core.syntax.SimplifiedJspServlet.renderProcess(SimplifiedJspServlet.java:201)
        at org.netbeans.modules.web.core.syntax.JSPProcessor$2.run(JSPProcessor.java:272)
        at org.netbeans.editor.BaseDocument.render(BaseDocument.java:1371)
        at org.netbeans.modules.web.core.syntax.JSPProcessor.process(JSPProcessor.java:268)
Comment 5 rdelaplante 2009-06-12 15:48:32 UTC
Created attachment 83510 [details]
stacktrace
Comment 6 rdelaplante 2009-06-12 15:49:23 UTC
Build: NetBeans IDE 6.7 RC2 (Build 200906042131)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: SunOS, 5.11, x86

User Comments: 
editing facelets files?

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.web.core.syntax.JSPProcessor.getImportsFromJspParser(JSPProcessor.java:319)
        at org.netbeans.modules.web.core.syntax.JSPProcessor.createImplicitImportStatements(JSPProcessor.java:295)
        at org.netbeans.modules.web.core.syntax.SimplifiedJspServlet.renderProcess(SimplifiedJspServlet.java:201)
        at org.netbeans.modules.web.core.syntax.JSPProcessor$2.run(JSPProcessor.java:272)
        at org.netbeans.editor.BaseDocument.render(BaseDocument.java:1371)
        at org.netbeans.modules.web.core.syntax.JSPProcessor.process(JSPProcessor.java:268)
Comment 7 rdelaplante 2009-06-12 15:49:32 UTC
Created attachment 83511 [details]
stacktrace
Comment 8 rdelaplante 2009-06-12 15:51:24 UTC
Build: NetBeans IDE 6.7 RC2 (Build 200906042131)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: SunOS, 5.11, x86

User Comments: 
I'm editing facelets files in 6.7 RC2.  The code completiong for facelets and jsf tags is not working and when I make changes to the page I keep getting an exception.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:ui="http://java.sun.com/jsf/facelets"
      xmlns:h="http://java.sun.com/jsf/html"
      xmlns:f="http://java.sun.com/jsf/core"
      xmlns:rich="http://richfaces.org/rich"
      xmlns:a4j="http://richfaces.org/a4j">


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.web.core.syntax.JSPProcessor.getImportsFromJspParser(JSPProcessor.java:319)
        at org.netbeans.modules.web.core.syntax.JSPProcessor.createImplicitImportStatements(JSPProcessor.java:295)
        at org.netbeans.modules.web.core.syntax.SimplifiedJspServlet.renderProcess(SimplifiedJspServlet.java:201)
        at org.netbeans.modules.web.core.syntax.JSPProcessor$2.run(JSPProcessor.java:272)
        at org.netbeans.editor.BaseDocument.render(BaseDocument.java:1371)
        at org.netbeans.modules.web.core.syntax.JSPProcessor.process(JSPProcessor.java:268)
Comment 9 rdelaplante 2009-06-12 15:51:33 UTC
Created attachment 83512 [details]
stacktrace
Comment 10 Tomasz Slota 2009-06-22 14:29:47 UTC
fixed,

http://hg.netbeans.org/web-main/rev/1eceb6f66b0f
Comment 11 Tomasz Slota 2009-06-22 16:55:43 UTC
corrected fix:

http://hg.netbeans.org/web-main/rev/7eb707a6da05
Comment 12 Quality Engineering 2009-06-23 07:43:28 UTC
Integrated into 'main-golden', will be available in build *200906230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7eb707a6da05
User: Tomasz Slota <tslota@netbeans.org>
Log: #166817: NPE @ JSPProcessor.getImportsFromJspParser (corrected fix)
Comment 13 Petr Blaha 2009-07-02 15:52:38 UTC
Can't reproduce in the latest trunk build for .xhtml pages.
Comment 14 jpleed3 2009-07-06 19:12:26 UTC
Can't this fix be sent down through the updater?
Comment 15 pgebauer 2009-07-07 11:47:37 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/94e1f71ef571
Comment 16 Jindrich Sedek 2009-07-15 14:29:32 UTC
the fix will be accessible through the updater next week
verified
NetBeans IDE 6.7.1 RC (Build 200907150227)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo