Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166703 - NullPointerException at org.netbeans.libs.bugtracking.BugtrackingRuntime.addRepositoryConnector
NullPointerException at org.netbeans.libs.bugtracking.BugtrackingRuntime.addR...
Status: VERIFIED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Jira
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Tomas Stupka
issues@connecteddeveloper
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
:
: 167255 167707 167905 168017 168082 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 08:36 UTC by vlad_konov
Modified: 2009-07-31 14:43 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.83 KB, text/plain)
2009-06-08 08:36 UTC, vlad_konov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vlad_konov 2009-06-08 08:36:36 UTC
Build: NetBeans IDE 6.7 RC1 (Build 200905282243)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Windows XP, 5.1, x86

User Comments:
GUEST: Attempting to commit changes via SVN

vlad_konov: trying to commit code to subversion



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.libs.bugtracking.BugtrackingRuntime.addRepositoryConnector(BugtrackingRuntime.java:120)
        at org.netbeans.modules.jira.Jira.<init>(Jira.java:87)
        at org.netbeans.modules.jira.Jira.getInstance(Jira.java:92)
        at org.netbeans.modules.jira.JiraConnector.getRepositories(JiraConnector.java:77)
        at org.netbeans.modules.bugtracking.BugtrackingManager.getRepositories(BugtrackingManager.java:119)
        at org.netbeans.modules.bugtracking.BugtrackingManager.getKnownRepositories(BugtrackingManager.java:104)
Comment 1 vlad_konov 2009-06-08 08:36:41 UTC
Created attachment 83298 [details]
stacktrace
Comment 2 Tomas Stupka 2009-06-08 15:34:26 UTC
fixed

changeset   : 134002:726a6513c63d
author      : Tomas Stupka <tstupka@netbeans.org>
date        : Mon Jun 08 16:34:08 CEST 2009
Comment 3 Quality Engineering 2009-06-11 08:56:32 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/726a6513c63d
User: Tomas Stupka <tstupka@netbeans.org>
Log: #166703 - NullPointerException at org.netbeans.libs.bugtracking.BugtrackingRuntime.addRepositoryConnector
Comment 4 Tomas Stupka 2009-06-22 13:04:20 UTC
*** Issue 167255 has been marked as a duplicate of this issue. ***
Comment 5 Tomas Stupka 2009-06-30 11:30:13 UTC
*** Issue 167707 has been marked as a duplicate of this issue. ***
Comment 6 Tomas Stupka 2009-06-30 16:33:50 UTC
*** Issue 167905 has been marked as a duplicate of this issue. ***
Comment 7 Tomas Stupka 2009-07-02 11:01:23 UTC
*** Issue 168017 has been marked as a duplicate of this issue. ***
Comment 8 Tomas Stupka 2009-07-03 11:25:45 UTC
*** Issue 168082 has been marked as a duplicate of this issue. ***
Comment 9 Jaromir Uhrik 2009-07-03 15:06:21 UTC
Reviewed fix and marking issue as VERIFIED.
Comment 10 pgebauer 2009-07-03 15:44:25 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/a0c3a9868107
Comment 11 pgebauer 2009-07-03 20:01:36 UTC
The another change has to be ported into the release67_fixes repository otherwise the build is broken.
http://hg.netbeans.org/release67_fixes/rev/dfebbe6661e3


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo