Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166625 - Variables view is left opened when debugger finishes.
Variables view is left opened when debugger finishes.
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
67patch1-verified
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-05 18:49 UTC by Martin Entlicher
Modified: 2009-07-16 15:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2009-06-05 18:49:20 UTC
Very often after debugger session is finished, Variables view is left opened.
Variables view should be closed together will all other debugger-related windows. This is a regression.
Comment 1 Martin Entlicher 2009-06-05 19:01:17 UTC
It was found, that all views are correctly closed, but then Variables window is opened again, due to CodeEvaluator:

        at java.lang.Thread.dumpStack(Thread.java:1206)
        at org.netbeans.modules.debugger.ui.views.View.componentShowing(View.java:107)
        at org.openide.windows.WindowManager.componentShowing(WindowManager.java:330)
        at org.netbeans.core.windows.WindowManagerImpl.componentShowing(WindowManagerImpl.java:1057)
        at org.netbeans.core.windows.view.DefaultView.changeGUI(DefaultView.java:161)
        at org.netbeans.core.windows.ViewRequestor.dispatchRequest(ViewRequestor.java:269)
        at org.netbeans.core.windows.ViewRequestor.processRequest(ViewRequestor.java:245)
        at org.netbeans.core.windows.ViewRequestor.postRequest(ViewRequestor.java:183)
        at org.netbeans.core.windows.ViewRequestor.scheduleRequest(ViewRequestor.java:123)
        at org.netbeans.core.windows.Central.activateModeTopComponent(Central.java:1753)
        at org.netbeans.core.windows.WindowManagerImpl.topComponentRequestActive(WindowManagerImpl.java:1180)
        at org.openide.windows.TopComponent.requestActive(TopComponent.java:789)
        at org.netbeans.modules.debugger.ui.views.View.requestActive(View.java:181)
        at org.netbeans.modules.debugger.jpda.ui.CodeEvaluator$7.run(CodeEvaluator.java:478)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
        at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 2 Vojtech Sigler 2009-06-09 09:12:58 UTC
Incorrect info in wiki:

67fixes1-candidate -> 67patch-candidate
Comment 3 Martin Entlicher 2009-06-09 15:28:35 UTC
Fixed in trunk in changeset:   134473:d99ea0393f0e
http://hg.netbeans.org/main/rev/d99ea0393f0e
Comment 4 Quality Engineering 2009-06-11 08:45:31 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d99ea0393f0e
User: mentlicher@netbeans.org
Log: #166625 - Do not open results when debugger is finishing.
Comment 5 Vojtech Sigler 2009-06-11 09:31:48 UTC
Could you please provide some steps to reproduce, so that I can verify? I was unable to reproduce this in earlier builds
nor in RC3. In all of about 15 attempts the Variables view remained closed.
Comment 6 Vojtech Sigler 2009-07-02 13:11:49 UTC
I was not able to reproduce this since the fix -> marking as verified.
Comment 7 pgebauer 2009-07-07 12:27:08 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/e62d8c270cb5
Comment 8 Filip Zamboj 2009-07-15 17:32:26 UTC
reproduced on 
Product Version: NetBeans IDE 6.7.1 RC (Build 200907150227)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02
Comment 9 Filip Zamboj 2009-07-16 15:07:18 UTC
verified in 671rc1 - variables window should stay open if you opened that window before running debugging session 
Comment 10 Filip Zamboj 2009-07-16 15:08:06 UTC
back to fixed
Comment 11 Filip Zamboj 2009-07-16 15:08:31 UTC
verified in 671rc1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo