Bug 166569 - Plugin uninstallation works badly on Solaris SPARC platform.
Plugin uninstallation works badly on Solaris SPARC platform.
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P4 (vote)
: 7.0
Assigned To: Jaroslav Tulach
issues@platform
: RELNOTE
: 175097 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 17:53 UTC by Michael Nazarov
Modified: 2010-11-25 12:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Whole cycle: install, reboot, uninstall, reboot (48.36 KB, application/x-gzip)
2009-06-05 10:31 UTC, Michael Nazarov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Nazarov 2009-06-04 17:53:07 UTC
There are number of different exceptions after installation/uninstallation/restart
cycle for XML and SOA plugins on Solaris SPARC platforms. Issue close to other one
#166254, check it for more details.
Comment 1 dlipin 2009-06-04 17:57:13 UTC
Please attach messages.log file.
Comment 2 dlipin 2009-06-04 18:34:25 UTC
BTW which modules have you uninstalled?
Comment 3 Marian Mirilovic 2009-06-05 08:33:23 UTC
michael, 
what is the difference between this issue and issue 166254 ?
Comment 4 Michael Nazarov 2009-06-05 08:40:56 UTC
There is no difference for me. But as I understand Jarda prefer two different
issues, for installation and uninstallation. My comment in other issue is:

Original title of this issue was not changed -- it's about installation and uninstallation.
But if you prefer to keep them separated -- not a problem.
Comment 5 Marian Mirilovic 2009-06-05 08:54:03 UTC
Aha, I see Michael... honestly I hadn't read all comments from issue 166254 before I commented this one - thanks for
explanation.
Comment 6 dlipin 2009-06-05 09:02:19 UTC
marking incomplete, please attach messages.log.
Comment 7 Michael Nazarov 2009-06-05 10:31:36 UTC
Created attachment 83226 [details]
Whole cycle: install, reboot, uninstall, reboot
Comment 8 dlipin 2009-06-05 10:43:35 UTC
Hm... a lot of following (and similar) exceptions are thrown.

INFO [org.netbeans.core.startup.NbEvents]: Warning: the module /home/mn153253/modules/org-netbeans-modules-xml-wsdl-
bindingsupport-api.jar could not be found, ignoring...
WARNING [org.netbeans.core.startup.ModuleList]: Error encountered while reading 
org.netbeans.modules.xml.wsdl.bindingsupport.api
java.lang.NullPointerException
[catch] at org.netbeans.core.startup.ModuleList$ReadInitial.run(ModuleList.java:1798)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:120)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:509)
	at org.netbeans.core.startup.ModuleList.readInitial(ModuleList.java:171)
	at org.netbeans.core.startup.ModuleSystem.readList(ModuleSystem.java:262)
	at org.netbeans.core.startup.Main.getModuleSystem(Main.java:167)
	at org.netbeans.core.startup.Main.start(Main.java:309)
	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:111)
	at java.lang.Thread.run(Thread.java:619)
Comment 9 Michael Nazarov 2009-06-05 10:52:26 UTC
Yes, looks like IDE did not catch moment of uninstallation and try to access
removed files again.
Comment 10 dlipin 2009-06-09 14:44:18 UTC
Marking as duplicate of 166254, the root cause is pretty much the same (handling lastModified stamps).
Can`t reproduce it if installation is done in non-NFS partition (e.g. /tmp).

*** This issue has been marked as a duplicate of 166254 ***
Comment 11 Jaroslav Tulach 2009-06-18 11:33:57 UTC
This problem does not seem to be duplicate of bug 166254, as bug 166254 is fixed yet michael can still see symptoms of
this problem.
Comment 12 Michael Nazarov 2009-06-18 11:37:29 UTC
The root cause seems to be the same, because if IDE restarted not immediately but
with delay long enough to pass time difference then exceptions do not appear.
Comment 13 Alexei Mokeev 2009-07-27 17:25:44 UTC
To have a chance to reproduce this issue you need to have:
1. NetBeans user dir on NFS partition
2. Wrong clocks on NFS server

In other words there should be a significant difference(tens of minutes) in time settings between NetBeans hosting
machine and NFS server. However it's yet possible combination I do not think that it's a P2.
Comment 14 dlipin 2009-10-26 20:25:02 UTC
*** Issue 175097 has been marked as a duplicate of this issue. ***
Comment 15 Jaroslav Tulach 2010-10-13 11:51:56 UTC
Easiest is to fix own NFS setup.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo