Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166495 - Erratic highlighting in Variables view
Erratic highlighting in Variables view
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
67patch1-verified
: REGRESSION
: 162940 169085 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 14:43 UTC by Vojtech Sigler
Modified: 2009-07-27 15:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vojtech Sigler 2009-06-03 14:43:29 UTC
Product Version: NetBeans IDE 6.7 RC2 (Build 200906030001)
Java: 1.6.0_14; Java HotSpot(TM) Client VM 14.0-b16
System: Linux version 2.6.28-11-generic running on i386; UTF-8; en_US (nb)

Confirmed also in trunk build:
Product Version: NetBeans IDE Dev (Build 200906021401)
Java: 1.6.0_14; Java HotSpot(TM) Client VM 14.0-b16
System: Linux version 2.6.28-11-generic running on i386; UTF-8; en_US (nb)

Highlighting of changed variables and watches in the Variables view behaves in an erratic way. In about 90% of cases the
value just flashes bold and becomes non-bold again. Sometimes it seems as if it was refreshed 2 times.

Steps to reproduce:
1) Open LineBreakpoints.java in MemoryView project
2) put breakpoint on line 195
3) create watches i, s, llist
4) Debug file
5) Open Variables view
6) Invoke Continue several times
7) Most times both changed variables and watches just flash bold and become non-bold again
Comment 1 Martin Entlicher 2009-06-03 15:19:51 UTC
Reproduced. This is broken by integration of Watches into Variables.
Comment 2 Martin Entlicher 2009-06-04 14:52:36 UTC
The Variables view is refreshed several times when Watches or Evaluator result or Variables request refresh.
Comment 3 Martin Entlicher 2009-06-10 16:09:22 UTC
Since this is an unpleasant regression, it should be considered as a candidate for 67 patch IMHO.

The refreshing problem is fixed by caching of the data of each model, that assures that only the model that fired the
event is refreshed.
Fixed in changeset:   134679:8fc8467d7eeb
http://hg.netbeans.org/main/rev/8fc8467d7eeb

A related fix that improves refresh experience is changeset:   134680:7701646d43cb
http://hg.netbeans.org/main/rev/7701646d43cb
Comment 4 Quality Engineering 2009-06-11 08:39:29 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8fc8467d7eeb
User: mentlicher@netbeans.org
Log: #166495 - The data of each model are cached, that assures that only the model that fires events is refreshed.
Comment 5 Vojtech Sigler 2009-06-11 09:06:38 UTC
Verified in trunk build. I agree that this should be included in 67 Patch. I will mark this as VERIFIED once it's
integrated in the patch (or rejected).
Comment 6 Filip Zamboj 2009-06-17 10:26:33 UTC
*** Issue 162940 has been marked as a duplicate of this issue. ***
Comment 7 Vojtech Sigler 2009-07-02 13:09:21 UTC
Marking as verified (trunk build 200907020200), so this can go to 67patch.
Comment 8 pgebauer 2009-07-07 12:21:47 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/b31f34c3548d
Comment 9 Daniel Prusa 2009-07-27 15:06:32 UTC
*** Issue 169085 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo