Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166487 - Fixed watch in Variables view is not fixed
Fixed watch in Variables view is not fixed
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 13:46 UTC by Vojtech Sigler
Modified: 2009-07-15 15:48 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vojtech Sigler 2009-06-03 13:46:36 UTC
Product Version: NetBeans IDE 6.7 RC2 (Build 200906030001)
Java: 1.6.0_14; Java HotSpot(TM) Client VM 14.0-b16
System: Linux version 2.6.28-11-generic running on i386; UTF-8; en_US (nb)

If I create a fixed watch, it is not fixed in the Variables view - refreshes just like a regular watch. However, in the
Watches view it works correctly.

Steps to reproduce:
1) Open MemoryView -> MemoryView.java
2) toggle a breakpoint on line 101
3) create a watch 'new Long(free)' and create a fixed watch from it
4) Debug project
5) Open Variables view
6) Invoke Continue
7) Both watches (including the fixed one) are refreshed
8) Open Watches view
9) Invoke Continue
10) only the non-fixed watch is refreshed
Comment 1 Martin Entlicher 2009-06-03 15:20:10 UTC
Reproduced. There's something bad about how fixed watches are treated...
Happens when Watches are integrated in Variables.
Comment 2 Filip Zamboj 2009-06-03 15:39:39 UTC
after discussion with martin we decided to lower priority of this issue. 

reason: fix is complicated and dangerous + there exists workaround 
workaround: use watches window instead of variables window if you use fixed watches 

=> p2 because of not working functionality. 67patch candidate. 

Not a showstopper anymore. 
Comment 3 Martin Entlicher 2009-06-04 13:55:33 UTC
The fixed watch is somehow broken by loading of local variables.
The fixed watch updates it's value even when watches are separated from Variables - when you switch to Variables and
then back to Watches.
Comment 4 Martin Entlicher 2009-06-04 14:50:25 UTC
Fixed in changeset:   134246:61e143cec540
http://hg.netbeans.org/main/rev/61e143cec540
Comment 5 Vojtech Sigler 2009-06-09 09:12:30 UTC
Incorrect info in wiki:

67fixes1-candidate -> 67patch-candidate
Comment 6 Quality Engineering 2009-06-11 08:51:59 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/660796202b04
User: mentlicher@netbeans.org
Log: Make the watch clon evaluated if the original was evaluated. This was found to be missing while exploring issue #166487.
Comment 7 Vojtech Sigler 2009-06-11 09:56:16 UTC
Verified in trunk build. Will mark as verified once it's integrated to 67patch.
Comment 8 Vojtech Sigler 2009-07-02 13:15:25 UTC
Marking as verified, so this can go to 67patch.
Comment 9 pgebauer 2009-07-03 13:03:04 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/9c6dfebd0cef


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo