Bug 166017 - GlassFish v3 not available on creating new project
GlassFish v3 not available on creating new project
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 10:47 UTC by Ivan Sidorkin
Modified: 2009-05-29 13:30 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2009-05-26 10:47:16 UTC
Product Version: NetBeans IDE 6.7 RC1 (Build 200905232021)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

full installation, ergonomics disabled

- open New Project Wizard
- select Java Web -> Web Application
- click Next twice
- on Server and Settings step expend Server combobox

there are only Tomcat and GFv2 in list
Comment 1 Marian Mirilovic 2009-05-26 11:13:52 UTC
This needs to be at least evaluated for NB 6.7
Comment 2 Michal Mocnak 2009-05-26 11:17:49 UTC
Tried on linux (debian sid amd64) and cannot reproduce. Everything functional. I'll try on msft system.
Comment 3 Ivan Sidorkin 2009-05-26 11:50:19 UTC
reproduced for me on WinXP and Ubuntu 8.10 with clean userdir
GFv3 become available after expanding Servers node in Services window
Comment 4 Michal Mocnak 2009-05-26 15:57:04 UTC
Reproduced. Easy workaround but very confusing for users marking as stopper. Upgrading to P1
Comment 5 Vince Kraemer 2009-05-26 16:20:43 UTC
please attach the IDE log file...
Comment 6 Vince Kraemer 2009-05-26 16:31:17 UTC
don't need the IDE log... I am able to reproduce the issue...
Comment 7 Vince Kraemer 2009-05-26 17:34:28 UTC
http://hg.netbeans.org/web-main/rev/82c82488e410
Comment 8 Nitya Doraisamy 2009-05-26 18:54:44 UTC
Fix reviewed.
Comment 9 Quality Engineering 2009-05-27 07:24:56 UTC
Integrated into 'main-golden', will be available in build *200905270201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/82c82488e410
User: vince kraemer <vkraemer@netbeans.org>
Log: #166017: instances list and default server are not initialized if the server node is not accessed.
Comment 10 Ivan Sidorkin 2009-05-27 11:18:09 UTC
verified with NetBeans IDE Dev (Build 200905270201)
Comment 11 Vince Kraemer 2009-05-27 13:13:03 UTC
the 'fix' triggered issue 166073, so I am back at the drawing board.
Comment 12 Vince Kraemer 2009-05-27 14:07:26 UTC
same fix strategy. moved into a location where the glassfish.javaee module is not going to be triggering manipulations
of the j2eeserver rregistry (which is the cause for the deadlock in issue 166073).

http://hg.netbeans.org/web-main/rev/eb1aac61ec52
Comment 13 _ tboudreau 2009-05-27 22:05:39 UTC
Sounds like the whole way these things are registered and found needs to be rethought - ModuleInstall.restored() is not
a good place for this sort of thing, although as an emergency workaround it may be necessary for now.  

Consider lookup registration or files somewhere in the SFS.  I don't see why a registry of anything should require that
much locking;  if it really does, consider providing *only* a callback interface to receive the collection of instances,
so you control the thread the registry lookup runs on (and therefore what locks are held - i.e. you make deadlocking on
it impossible).
Comment 14 davisn 2009-05-27 22:53:58 UTC
Fixed verified with procedure and build below

NetBeans-dev-web-main-709-on-090527-full build from (http://bertram.netbeans.org/hudson/job/web-main/lastSuccessfulBuild/)

-Added and Registered GlassFish v3 Prelude & V3 Enterprise
-Created a web project -> select GlassFish v3 Prelude or V3 Enterprise in the server list
Comment 15 Vince Kraemer 2009-05-28 00:14:21 UTC
http://hg.netbeans.org/release67/rev/01402266d151
Comment 16 Quality Engineering 2009-05-28 08:43:02 UTC
Integrated into 'main-golden', will be available in build *200905280201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/eb1aac61ec52
User: vince kraemer <vkraemer@netbeans.org>
Log: #166017: initialize the glassfish registry (and the default domain) before the downstream modules start to initialize.
Comment 17 Michal Mocnak 2009-05-29 13:30:07 UTC
Verified in 6.7rc1 build #200905282243


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo