Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 165880 - [67cat] java.util.ConcurrentModificationException at java.util.AbstractList$Itr.checkForComodification
[67cat] java.util.ConcurrentModificationException at java.util.AbstractList$I...
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P3 with 2 votes (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
http://statistics.netbeans.org/except...
67patch1-verified EXCEPTIONS_REPORT
: SIMPLEFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-23 16:19 UTC by big_al
Modified: 2009-09-30 20:00 UTC (History)
14 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (913 bytes, text/plain)
2009-05-23 16:19 UTC, big_al
Details
stacktrace (913 bytes, text/plain)
2009-06-11 17:18 UTC, aldobrucale
Details
stacktrace (913 bytes, text/plain)
2009-06-17 09:51 UTC, aldobrucale
Details
stacktrace (913 bytes, text/plain)
2009-07-13 12:18 UTC, mohhmekk
Details
stacktrace (913 bytes, text/plain)
2009-07-15 10:33 UTC, pzajac
Details
stacktrace (913 bytes, text/plain)
2009-07-21 18:51 UTC, pzajac
Details
stacktrace (913 bytes, text/plain)
2009-07-29 15:11 UTC, Jan Becicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description big_al 2009-05-23 16:19:26 UTC
Build: NetBeans IDE Dev (Build 200905220201)
VM: Java HotSpot(TM) 64-Bit Server VM, 1.6.0_07-b06-57, Java(TM) SE Runtime Environment, 1.6.0_07-b06-153
OS: Mac OS X, 10.5.7, x86_64

User Comments:
big_al: Started debugging a Maven enterprise application



Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
        at java.util.AbstractList$Itr.next(AbstractList.java:343)
        at org.netbeans.modules.debugger.jpda.models.ThreadsCache.setVirtualMachine(ThreadsCache.java:133)
        at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.setRunning(JPDADebuggerImpl.java:1316)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.doStartDebugger(StartActionProvider.java:203)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.access$100(StartActionProvider.java:73)
Comment 1 big_al 2009-05-23 16:19:33 UTC
Created attachment 82691 [details]
stacktrace
Comment 2 Martin Entlicher 2009-05-24 13:18:47 UTC
Fixed in changeset:   133346:bc8516fd60c7
http://hg.netbeans.org/main/rev/bc8516fd60c7
Comment 3 Quality Engineering 2009-05-25 07:28:59 UTC
Integrated into 'main-golden', will be available in build *200905250201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/bc8516fd60c7
User: mentlicher@netbeans.org
Log: #165880 - Prevent from ConcurrentModificationException.
Comment 4 aldobrucale 2009-06-11 17:18:00 UTC
Build: NetBeans IDE 6.7 RC2 (Build 200906042131)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-11-generic, i386

User Comments: 


Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
        at java.util.AbstractList$Itr.next(AbstractList.java:343)
        at org.netbeans.modules.debugger.jpda.models.ThreadsCache.setVirtualMachine(ThreadsCache.java:133)
        at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.setRunning(JPDADebuggerImpl.java:1316)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.doStartDebugger(StartActionProvider.java:203)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.access$100(StartActionProvider.java:73)
Comment 5 aldobrucale 2009-06-11 17:18:15 UTC
Created attachment 83452 [details]
stacktrace
Comment 6 Martin Entlicher 2009-06-11 20:38:41 UTC
Since this is trivial to fix, marking as a candidate for 67 patch.
Comment 7 aldobrucale 2009-06-17 09:51:44 UTC
Build: NetBeans IDE 6.7 RC3 (Build 200906142201)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-11-generic, i386

User Comments: 


Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
        at java.util.AbstractList$Itr.next(AbstractList.java:343)
        at org.netbeans.modules.debugger.jpda.models.ThreadsCache.setVirtualMachine(ThreadsCache.java:133)
        at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.setRunning(JPDADebuggerImpl.java:1316)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.doStartDebugger(StartActionProvider.java:203)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.access$100(StartActionProvider.java:73)
Comment 8 aldobrucale 2009-06-17 09:51:50 UTC
Created attachment 83678 [details]
stacktrace
Comment 9 Vojtech Sigler 2009-07-02 13:26:04 UTC
big_al or anyone who experienced this, can you, please, verify?
Comment 10 big_al 2009-07-02 22:02:20 UTC
It's still there when you start debugging an application for the first time. After the first time it goes away until restarting NetBeans.
Comment 11 Martin Entlicher 2009-07-02 22:07:12 UTC
In which NetBeans version is it there?
Can you please attach the exception here?
Comment 12 Martin Entlicher 2009-07-02 22:22:37 UTC
Looking at http://statistics.netbeans.org/exceptions/detail.do?id=151678 it's apparent that this exception is thrown in
6.7 builds and dev builds older than 200905250201. Therefore I believe this is really fixed.

Please note that this issue is fixed in 6.8 (dev) builds only and newer than 200905250201.
Please verify in 6.8 (dev) build. Thanks.
Comment 13 limo42 2009-07-03 09:45:17 UTC
99.9% of the IDE users arent't interested in any dev builds at all. 
We need this fix patched into the 6.7 release *Real Soon Now*. Thanks.
Comment 14 Vojtech Sigler 2009-07-03 10:05:43 UTC
limo42, before we can add this fix to 67patch, it needs to be verified that it is really fixed. I would verify it
myself, but there are no steps to reproduce this issue. If you can provide some steps to reproduce and/or a sample
project where this issue occurs, it will be greatly appreciated.
Comment 15 big_al 2009-07-03 10:10:51 UTC
I'll download a dev release over the weekend and try it out.

To reproduce on 6.7:

1. Start NetBeans
2. Invoke the "Debug" option for a Maven enterprise application

You'll see the Exception icon in the status bar

I believe the Exception appears when invoking the "Debug" option for other project types, but haven't verified as I'm mainly working on Maven projects.
Comment 16 Vojtech Sigler 2009-07-03 10:45:18 UTC
I played around a bit and managed to reproduce this in an older build, but not in the latest dev build. Marking as
verified. Thanks everyone :)
Comment 17 akiliyevich 2009-07-03 10:46:53 UTC
Such problem is too hardly to reproduce.
Its appears first time yesterday when I migrated to release of NetBeans IDE 6.7 (Build 200906241340), clean&build out
JAVA project and run it in debug mode.
The second attempt was successful.
Second time its appears at the end of day.
Today it doesn't appears.

I'm very happy that resolved another synchronization problem - conflict on file access between 'Project scanning' and 
'Build' in 6.5, now its nether scan during build.
Comment 18 limo42 2009-07-03 13:56:05 UTC
Reproduces for a large module suite project in the 6.7 release, but doesn't happen anymore in 
the latest 6.8 nightly, NetBeans IDE Dev (Build 200907030200).
So, I'd say your're ready to go for that patch. Thanks, everybody.
Comment 19 pgebauer 2009-07-07 11:52:09 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/9631daf2927e
Comment 20 mohhmekk 2009-07-13 12:18:22 UTC
Build: NetBeans IDE 6.7 (Build 200906241340)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Linux, 2.6.28-13-generic, i386

User Comments: 


Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
        at java.util.AbstractList$Itr.next(AbstractList.java:343)
        at org.netbeans.modules.debugger.jpda.models.ThreadsCache.setVirtualMachine(ThreadsCache.java:133)
        at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.setRunning(JPDADebuggerImpl.java:1316)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.doStartDebugger(StartActionProvider.java:203)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.access$100(StartActionProvider.java:73)
Comment 21 mohhmekk 2009-07-13 12:18:43 UTC
Created attachment 84649 [details]
stacktrace
Comment 22 pzajac 2009-07-15 10:33:09 UTC
Build: NetBeans IDE 6.7 (Build 200906241340)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.24-24-generic, i386

User Comments: 


Stacktrace: 
java.util.ConcurrentModificationException<br/>
        at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)<br/>
        at java.util.AbstractList$Itr.next(AbstractList.java:343)<br/>
        at org.netbeans.modules.debugger.jpda.models.ThreadsCache.setVirtualMachine(ThreadsCache.java:133)<br/>
        at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.setRunning(JPDADebuggerImpl.java:1316)<br/>
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.doStartDebugger(StartActionProvider.java:203)<br/>
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.access$100(StartActionProvider.java:73)<br/>
Comment 23 pzajac 2009-07-15 10:33:32 UTC
Created attachment 84759 [details]
stacktrace
Comment 24 Filip Zamboj 2009-07-15 17:51:15 UTC
I verified this bug and cannot reproduce again. However, I see that are some reports from later builds. Please, provide
steps to reproduce this issue. Would help us a lot. Thanks. 
Comment 25 pzajac 2009-07-21 18:51:31 UTC
Build: NetBeans IDE 6.7 (Build 200906241340)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.24-24-generic, i386

User Comments: 


Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
        at java.util.AbstractList$Itr.next(AbstractList.java:343)
        at org.netbeans.modules.debugger.jpda.models.ThreadsCache.setVirtualMachine(ThreadsCache.java:133)
        at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.setRunning(JPDADebuggerImpl.java:1316)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.doStartDebugger(StartActionProvider.java:203)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.access$100(StartActionProvider.java:73)
Comment 26 pzajac 2009-07-21 18:51:36 UTC
Created attachment 85033 [details]
stacktrace
Comment 27 Jan Becicka 2009-07-29 15:11:22 UTC
Build: NetBeans IDE 6.7 (Build 200906241340)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Linux, 2.6.25.20-0.4-default, amd64

User Comments: 


Stacktrace: 
java.util.ConcurrentModificationException
        at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
        at java.util.AbstractList$Itr.next(AbstractList.java:343)
        at org.netbeans.modules.debugger.jpda.models.ThreadsCache.setVirtualMachine(ThreadsCache.java:133)
        at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.setRunning(JPDADebuggerImpl.java:1316)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.doStartDebugger(StartActionProvider.java:203)
        at org.netbeans.modules.debugger.jpda.actions.StartActionProvider.access$100(StartActionProvider.java:73)
Comment 28 Jan Becicka 2009-07-29 15:11:38 UTC
Created attachment 85464 [details]
stacktrace


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo