Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 165694 - socket communication should not block AWT
socket communication should not block AWT
Status: VERIFIED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
6.x
Sun Linux
: P3 (vote)
: 6.x
Assigned To: Marian Petras
issues@connecteddeveloper
67patch1-verified
: PERFORMANCE
: 166102 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 12:45 UTC by Jindrich Sedek
Modified: 2009-07-27 09:20 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
full stacktrace (4.82 KB, text/plain)
2009-05-21 12:45 UTC, Jindrich Sedek
Details
patch - the default bug-tracking repository is now determined asynchronously (17.30 KB, patch)
2009-05-29 20:47 UTC, Marian Petras
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2009-05-21 12:45:04 UTC
I invoked commit on my project shared on kenai -> ide become blocked for about ten seconds, I was successfull to create 
a threaddump some thread is working with sockets in AWT:


	at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:687)
	at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:632)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1049)
	- locked <0x00007f56a0a7f518> (a sun.net.www.protocol.https.DelegateHttpsURLConnection)
	at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:373)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:318)
	at org.netbeans.modules.kenai.RestConnection.connect(RestConnection.java:228)
	at org.netbeans.modules.kenai.RestConnection.get(RestConnection.java:137)
	at org.netbeans.modules.kenai.KenaiREST.getProject(KenaiREST.java:110)
	at org.netbeans.modules.kenai.api.Kenai._getProject(Kenai.java:417)
Comment 1 Jindrich Sedek 2009-05-21 12:45:31 UTC
Created attachment 82542 [details]
full stacktrace
Comment 2 Milan Kubec 2009-05-21 13:02:22 UTC
Please evaluate.
Comment 3 Jan Becicka 2009-05-21 13:46:00 UTC
It looks like this project was not found in cache. It means that it was not touched before (e.g. loaded by dashboard)
Comment 4 Tomas Stupka 2009-05-21 13:48:44 UTC
> It looks like this project was not found in cache. It means that it was not touched before (e.g. loaded by dashboard)
however, we the commit shouldn't make that call in awt. will fix it.
Comment 5 Tomas Stupka 2009-05-27 12:59:08 UTC
*** Issue 166102 has been marked as a duplicate of this issue. ***
Comment 6 Marian Petras 2009-05-29 20:47:04 UTC
Created attachment 83002 [details]
patch - the default bug-tracking repository is now determined asynchronously
Comment 7 Marian Petras 2009-05-30 21:08:22 UTC
Fixed.

Changeset:
6355a776119a

The routine that determines the issue tracking repository to be preselected is now called from a separate thread (using
RequestProcessor.getDefault()) so it does not block the AWT thread. The routine does not start until the Commit dialogue
is displayed (exactly: until it is made displayable). If the routine finishes its jobs successfully, the default
repository (as determined by the routine) is pre-selected in the Issue Tracker combo-box, unless the user had already
selected one.

If the pop-up of the Issue Tracker combo-box is displayed at the moment the routine determines the default repository
and the user had not selected one themselves, the default repository is not selected as long as the pop-up is visible.
Then, if the user selects some repository from the pop-up, their selection is respected, i.e. not changed to the default
repository. If the user has not selected any repository from the pop-up, the the default repository is selected as soon
as the combo-box's pop-up is closed. UI experts, if you think you know of a better solution, please speak up.
Comment 8 Quality Engineering 2009-05-31 07:47:34 UTC
Integrated into 'main-golden', will be available in build *200905310201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6355a776119a
User: Marian Petras <mpetras@netbeans.org>
Log: fixed bug #165694 ("socket communication should not block AWT")
Comment 9 Marian Mirilovic 2009-07-09 14:25:12 UTC
67patch1 ... fix of this issue is a part of changesets in issue 166591
Comment 10 pgebauer 2009-07-09 23:11:10 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/f2e027b51427


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo