Bug 165666 - I18N : "Unexpected" is not from bundle, better to use more useful hint
I18N : "Unexpected" is not from bundle, better to use more useful hint
Status: RESOLVED DUPLICATE of bug 106162
Product: ruby
Classification: Unclassified
Component: Hints
6.x
All All
: P2 (vote)
: TBD
Assigned To: Erno Mononen
issues@ruby
JA_COMMUNITY
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 06:25 UTC by Masaki Katakai
Modified: 2009-05-21 07:49 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (23.26 KB, image/png)
2009-05-21 06:32 UTC, Masaki Katakai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Masaki Katakai 2009-05-21 06:25:51 UTC
Product Version: NetBeans IDE Dev (Build 200905181401)
Java: 1.6.0_07; Java HotSpot(TM) 64-Bit Server VM 1.6.0_07-b06-57
System: Mac OS X version 10.5.7 running on x86_64 ; SJIS; ko (nb)

When Japanese is used in class name, it's invalid usage so
error should happen. However, it seems that the "Unexpected" hint
on editor is not from bundle. I could not find the exact code in
NetBeans source tree.

Also just "Unexpected" is not reasonable hint for users who do not
know Japanese can not be used in class name.
Comment 1 Masaki Katakai 2009-05-21 06:32:35 UTC
Created attachment 82525 [details]
screenshot
Comment 2 Erno Mononen 2009-05-21 07:46:36 UTC
The message comes directly from the parser, not much we can do on the IDE side right now.

*** This issue has been marked as a duplicate of 106162 ***
Comment 3 Masaki Katakai 2009-05-21 07:49:40 UTC
I see, thank you for the evaluation.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo