Bug 165638 - Autojoin even with closed Chat Window
Autojoin even with closed Chat Window
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Chat
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jan Becicka
issues@connecteddeveloper
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 18:42 UTC by Marco Walther
Modified: 2009-09-09 09:15 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Walther 2009-05-20 18:42:19 UTC
netbeans-Build 200905191401

I started NB, made sure the chat window is closed & logged into kenai. It looks like NB decided to join the chat rooms
for all my projects, even when I did not want to join from NB.

When I tried to join from Pidgin/any other client, I get a 409/conflict on the chat rooms:-( That's not what I expected.

Thanks,
-- Marco
Comment 1 Petr Dvorak 2009-05-20 19:34:01 UTC
Currently, this behaviour is as designed (=not a defect) - you log in to XMPP and join the rooms right after you log in
to Kenai... but I definitely admit this is not very handy. We should allow users to leave/enter an individual chat rooms
on demand.
Comment 2 Marco Walther 2009-05-20 21:28:02 UTC
Or at least join only when the user has a chat window open. So there is a slight chance that she will actually try to
use the chat feature in NB. As it is right now, this feature will prevent me from using the NB-> kenai integration.

Thanks,
-- Marco
Comment 3 Marian Mirilovic 2009-05-20 23:23:27 UTC
agreed with Marco / joshis - but honestly not doable for 6.7, just because we've got chatrooms too late ;(
Comment 4 Jan Becicka 2009-06-11 10:34:59 UTC
This is as designed.
>> As it is right now, this feature will prevent me from using the NB-> kenai integration.
Don't understand how it prevents you from using it.

The idea behind this behavior is, that you can use kenai with no additional setup. Once you are logged in, you see all
messages from all your project. Maybe we can add simple popup menu to lower right "online" icon allowing to go
online/offline.
Comment 5 Petr Dvorak 2009-06-11 13:40:13 UTC
... someone still prefers a native/more featured client. Currently, you cannot use Kenai with some external client for chat.

It could be possible to add an option "Auto-join all chat rooms" (on by default) and if user unselects this option,
he/she would join a room when he/she opens it in chat window and leave the room when he/she closes the chatroom tab... ?

Off-Topic: Do we plan to have an options panel for Kenai?
Comment 6 Jan Becicka 2009-06-11 13:52:48 UTC
we auto join because we want to have things simple. If member of my project is online, it means, that he can read
project chat. 

Comment 7 Ondrej Langr 2009-06-11 14:48:02 UTC
As for allowing not to join automatically - standard "status" known from messaging clients is a more standard and easier
to find solution then an option. It probably also integrates better with "presence" changes planned for the next release. 
Comment 8 Quality Engineering 2009-09-04 03:57:16 UTC
Integrated into 'main-golden', will be available in build *200909032054* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d8e9d0586ea3
User: Jan Becicka <jbecicka@netbeans.org>
Log: Possibility to log into kenai without chat
#165638:
#166822:
Comment 9 Jan Becicka 2009-09-09 09:15:16 UTC
Fixed. We still join all your chat rooms, but you have possibility not to use chat.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo