Bug 16468 - NPE in Request Processor when expanding DbSchema table node
NPE in Request Processor when expanding DbSchema table node
Status: CLOSED INVALID
Product: db
Classification: Unclassified
Component: Code
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: issues@db
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-11 13:53 UTC by vnemec
Modified: 2003-06-30 17:18 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
exception stack trace (6.22 KB, text/plain)
2001-10-11 13:55 UTC, vnemec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vnemec 2001-10-11 13:53:18 UTC
[orion 011010_1, jdk1.3.1, redhat7.1]

to reproduce:
a) start PointBase server ('Tools > PointBase Network Server > Start Server'
b) create new dbschema using existing connection  ('New > Databases > DFatabase
Schema', connection jdbc:pointbase://localhost.....)

try to expand some nodes - after while NullPointer Exception from Request
Processor will occure - see attachment
Comment 1 vnemec 2001-10-11 13:55:38 UTC
Created attachment 2960 [details]
exception stack trace
Comment 2 vnemec 2001-10-11 13:57:30 UTC
only typo in summary corrected...
Comment 3 Peter Zavadsky 2001-10-11 15:10:48 UTC
Problem is with a node of type:
com.sun.forte4j.modules.dbmodel.nodes.TableElementNode
its getName() method returns null what's illegal, it's displayName
returns valid value.

Reassigned.
Comment 4 Peter Zavadsky 2001-10-11 15:38:08 UTC
I updated NodeOp so the exception thrown now more clearly describes
the problem and also points to the original node if the node is of
FilterNode instance. Now if you try out the issue you'll see also the
TableElementNode as original to the Filter one to see there is the
problem.

Change:
openide/../nodes/NodeOp.java [1.29]
Comment 5 Radko Najman 2001-10-12 11:13:48 UTC
It is not a Database Explorer bug but Database Schema bug. Closing as 
INVALID and file bug report against Database Schema module in Bugtraq.
Comment 7 Martin Schovanek 2003-03-12 14:04:45 UTC
VERIFIED
Comment 8 Quality Engineering 2003-06-30 17:18:06 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo