Bug 164024 - ArrayIndexOutOfBoundsException: 8
ArrayIndexOutOfBoundsException: 8
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 164027 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 10:13 UTC by Jindrich Sedek
Modified: 2009-10-20 14:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.46 KB, text/plain)
2009-04-29 10:13 UTC, Jindrich Sedek
Details
stacktrace (2.04 KB, text/plain)
2009-09-22 13:04 UTC, Jiri Rechtacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2009-04-29 10:13:26 UTC
Build: NetBeans IDE Dev (Build 200904290201)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Linux, 2.6.27.21-170.2.56.fc10.x86_64, amd64

User Comments:
jsedek: I've connected to MYSQL DB
marked default schema
opened SQL script
started SQL script -> finished OK
clicked on default schema to expand Tables node -> AIOOBE was thrown



Stacktrace: 
org.openide.util.RequestProcessor$Item: task failed: java.lang.ArrayIndexOutOfBoundsException: 8
        at org.openide.util.RequestProcessor$Item.fillInStackTrace(RequestProcessor.java:853)
        at java.lang.Throwable.<init>(Throwable.java:181)
        at java.lang.Exception.<init>(Exception.java:29)
        at org.openide.util.RequestProcessor$Item.<init>(RequestProcessor.java:819)
        at org.openide.util.RequestProcessor$Task.schedule(RequestProcessor.java:629)
        at org.openide.nodes.AsynchChildren.refresh(AsynchChildren.java:119)
Comment 1 Jindrich Sedek 2009-04-29 10:13:35 UTC
Created attachment 81174 [details]
stacktrace
Comment 2 Jindrich Sedek 2009-04-29 10:15:33 UTC
the same exception si thrown while invoking refresh on schema node
Comment 3 Jiri Rechtacek 2009-04-30 15:13:48 UTC
*** Issue 164027 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Rechtacek 2009-07-01 07:44:31 UTC
NB6.7 was released already - http://www.netbeans.org/community/releases/67/
Postpone fixing this issue on the next release.
Comment 5 Exceptions Reporter 2009-09-21 16:22:52 UTC
This issue already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=150288
Comment 6 Jiri Rechtacek 2009-09-22 13:04:38 UTC
Build: NetBeans IDE Dev (Build 090918)
VM: Java HotSpot(TM) Client VM, 14.0-b12, Java(TM) SE Runtime Environment, 1.6.0_14-ea-b03
OS: Linux, 2.6.28-15-generic, i386

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.db.explorer.node.ProcedureParamNodeProvider$1.run(ProcedureParamNodeProvider.java:118)
        at org.netbeans.modules.db.explorer.node.ProcedureParamNodeProvider$1.run(ProcedureParamNodeProvider.java:98)
        at org.netbeans.modules.db.metadata.model.JDBCConnMetadataModel.runReadAction(JDBCConnMetadataModel.java:94)
        at org.netbeans.modules.db.metadata.model.api.MetadataModel.runReadAction(MetadataModel.java:89)
        at org.netbeans.modules.db.explorer.node.ProcedureParamNodeProvider.initialize(ProcedureParamNodeProvider.java:97)
        at org.netbeans.api.db.explorer.node.NodeProvider.getNodes(NodeProvider.java:103)
Comment 7 Jiri Rechtacek 2009-09-22 13:04:44 UTC
Created attachment 88099 [details]
stacktrace
Comment 8 Exceptions Reporter 2009-09-22 13:04:49 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=150288
Comment 9 Jiri Rechtacek 2009-09-22 14:34:28 UTC
core-main/rev/7487a87080eb
Comment 10 Quality Engineering 2009-09-24 12:35:31 UTC
Integrated into 'main-golden', will be available in build *200909230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7487a87080eb
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #164024: NPE at org.netbeans.modules.db.explorer.node.ProcedureParamNodeProvider$1.run(ProcedureParamNodeProvider.java:118)
Comment 11 Jindrich Sedek 2009-10-20 14:55:41 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo