Bug 16393 - Ant build does not work - EX on Win from MakeListOfNBM
Ant build does not work - EX on Win from MakeListOfNBM
Status: CLOSED FIXED
Product: www
Classification: Unclassified
Component: Builds & Repositories
3.x
PC Windows 3.1/NT
: P1 (vote)
: 3.x
Assigned To: nbbuild-issues@ide
nbbuild-issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-09 15:55 UTC by Pavel Buzek
Modified: 2003-07-02 08:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Buzek 2001-10-09 15:55:44 UTC
java.lang.IllegalStateException: C:\nb\testbuild\ant\netbeans\docs\ant-api.zip
        at org.netbeans.nbbuild.MakeListOfNBM.execute(MakeListOfNBM.java:103)
        at org.apache.tools.ant.Target.execute(Target.java:153)
        at org.apache.tools.ant.Project.runTarget(Project.java:898)
        at org.apache.tools.ant.Project.executeTarget(Project.java:536)
        at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:213)
        at org.apache.tools.ant.Target.execute(Target.java:153)
        at org.apache.tools.ant.Project.runTarget(Project.java:898)
        at org.apache.tools.ant.Project.executeTarget(Project.java:536)
        at org.netbeans.nbbuild.NbMerge.execute(Unknown Source)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:124)
        at org.apache.tools.ant.Target.execute(Target.java:153)
        at org.apache.tools.ant.Project.runTarget(Project.java:898)
        at org.apache.tools.ant.Project.executeTarget(Project.java:536)
        at org.apache.tools.ant.Project.executeTargets(Project.java:510)
        at org.apache.tools.ant.Main.runBuild(Main.java:421)
        at org.apache.tools.ant.Main.main(Main.java:149)
Comment 1 Pavel Buzek 2001-10-09 15:59:10 UTC
The problem is caused by using hardcoded "/" as folder separator (line 103, "/netbeans/"). Use 
java.io.File.separator instead!
Comment 2 rbalada 2001-10-09 16:23:28 UTC
I already know about that. Fixed has been applied.
Comment 3 _ ttran 2001-10-09 17:00:03 UTC
> I already know about that. Fixed has been applied.

then why haven't you close the bug?
Comment 4 rbalada 2001-10-09 17:16:16 UTC
Because I'm not author of the fix. It was pretested by someone else so I committed that w/o my own 
Windows build. Windows build run right now. I cannot close the issue, when I cannot be sure it's OK.

It's fixed and works on Solaris, but must be tested on Win32.

Marking the issue resolved fixed.
Comment 5 rbalada 2001-10-09 17:18:36 UTC
Verified. Build on Windows is now possible
Comment 6 Pavel Buzek 2003-07-02 08:57:37 UTC
closing


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo