Bug 163676 - ClassNotFoundException: org.netbeans.modules.xml.jaxb.model.JAXBWizProjectOpenedHookImpl
ClassNotFoundException: org.netbeans.modules.xml.jaxb.model.JAXBWizProjectOpe...
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Module System
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: ERGONOMICS
: 164378 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-25 22:35 UTC by Lukas Hasik
Modified: 2009-07-02 16:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.50 KB, text/plain)
2009-04-25 22:35 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2009-04-25 22:35:01 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904230001)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-11-generic, amd64

User Comments:
lhasik: 1, start IDE
2, close IDE
3, comment out ergonomics1 from clusters.conf
4, start IDE -> more exceptions



Stacktrace: 
java.lang.ClassNotFoundException: org.netbeans.modules.xml.jaxb.model.JAXBWizProjectOpenedHookImpl starting from org.netbeans.MainImpl$BootClassLoader@2a0ecd7e with possible defining loaders [ModuleCL@6c98a8b8[org.netbeans.modules.xml.jaxb]] and declared parents []
        at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:259)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
        at org.netbeans.modules.projectapi.LazyLookupProviders.loadPSPInstance(LazyLookupProviders.java:96)
        at org.netbeans.modules.projectapi.LazyLookupProviders.access$000(LazyLookupProviders.java:62)
        at org.netbeans.modules.projectapi.LazyLookupProviders$1$1.beforeLookup(LazyLookupProviders.java:78)
        at org.openide.util.lookup.ProxyLookup$R.myBeforeLookup(ProxyLookup.java:645)
Comment 1 Lukas Hasik 2009-04-25 22:35:06 UTC
Created attachment 80931 [details]
stacktrace
Comment 2 Jaroslav Tulach 2009-04-27 16:20:16 UTC
Another issue with Class loading. The message:
[ModuleCL@6c98a8b8[org.netbeans.modules.xml.jaxb]] and declared parents []
seems strange, because the the xml.jaxb module has a lot of dependencies.
Comment 3 Jesse Glick 2009-04-28 00:25:26 UTC
I cannot reproduce according to those instructions. Are you omitting some steps?

About the message - the declared parents are those of MainImpl.BootClassLoader, for which [] is correct. The issue is
that when LazyLookupProviders.loadPSPInstance is called, Thread.currentThread.contextClassLoader is still MI.BCL, rather
than ModuleManager.SystemClassLoader. This would be true during early startup, before the module system is really
initialized.

Why the above code is running at that time, I don't know. I can try to change RequestProcessor to effectively set SLOW
to true when running with assertions on, since we generally want to capture origin stack traces in development builds.
Comment 4 Quality Engineering 2009-04-28 18:54:10 UTC
Integrated into 'main-golden', will be available in build *200904281401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/3b30abd0e2b6
User: Jesse Glick <jglick@netbeans.org>
Log: Turning on "slow" mode (i.e. show who posted an RP task that ended in failure) whenever asserts are on.
Also improve display of result to be a single log record, better for exception reporter.
See #163676 for an example bug report which could more easily be diagnosed with such information.
Comment 5 Jesse Glick 2009-05-05 17:30:21 UTC
*** Issue 164378 has been marked as a duplicate of this issue. ***
Comment 6 Jesse Glick 2009-07-02 16:27:18 UTC
Nothing new for a couple of months.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo