Bug 163649 - Cannot create a web project
Cannot create a web project
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@javaee
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-25 01:28 UTC by _ tboudreau
Modified: 2009-04-30 11:58 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Is it really broken? (132.38 KB, image/png)
2009-04-27 12:27 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2009-04-25 01:28:37 UTC
1.  Start NetBeans on a clean userdir w/ ergonomics enabled (in my case I did have the modules attached to issue 163648
installed - don't know if this makes a difference).
2.  Go to New Project > Web.
3.  Click next, let it enable EJB & WAR, and keep going until you get to the page where you should select a server
(there will not be any).
4.  Click Add to add a server.
PROBLEM 1:  You get a dialog saying there are no server plugins installed and you should go to Tools > Plugins to
install one.  There are server plugins installed, they are just enabled, and going to Tools > Plugins won't help you.
5.  Close the wizard, go to Services > Servers.  Click Add Server.
6.  You get a dialog offering to download Glassfish V3 Prelude.  Okay, download it and finish the server wizard.
7.  Now try again to create a Web project.
8.  Click next until you get to the page where you should select a server.
PROBLEM 2:  There are no servers listed in the server combo box - you cannot create a web project
9.  Restart the IDE.  Now you can create a web project.

Problem 1 should probably be solved by enabling any server plugins when you try to create a web project, and fixing the
text on the Add button to tell people to try the Services > Servers node (where Add should also enable any server
plugins if not already enabled).

Problem 2 looks like some kind of caching issue where the wizard is keeping an empty list of servers after one has been
installed.
Comment 1 David Konecny 2009-04-27 00:21:03 UTC
I have not tried to reproduce this but if it is true then this is P1 regression which should be fixed in beta - we do
not want to create any obstacles for a fresh user trying out NB for the first time. Yarda, please evaluate and lower
priority if impact is limited. Thanks.
Comment 2 Petr Jiricka 2009-04-27 12:22:51 UTC
I can not reproduce, everything works correctly for me (all server plugins are enabled on step 4). Tim, can you please
include the details about your platform, JDK etc? Thanks.
Comment 3 Jaroslav Tulach 2009-04-27 12:27:58 UTC
Created attachment 80965 [details]
Is it really broken?
Comment 4 _ tboudreau 2009-04-27 12:41:42 UTC
There are two variables that may affect it:

1.  It seems that the Glassfish V3 module is smart enough to detect if Glassfish V3 is installed - if you have a copy of
it, probably you want to test this without Glassfish locatable

2.  The problem may be caused by the enablement of only some of the Java modules by having the Java Card modules
installed - it may be a combination that was not anticipated (but if so, I'm sure there are many other modules that
could cause such unplanned situations - my biggest fear about shipping ergonomics is problems when random third-party
modules are added to the mix and change enablement order in unexpected or unanticipated ways - a lot of the bugs have
been existing problems that never happened because load/enablement order was more predictable than it will be now)
Comment 5 Jaroslav Tulach 2009-04-27 12:49:59 UTC
Tim, I cannot reproduce your problem. See the attached screenshot. Can you please provide some more details about your 
environment? Your build #, list of enabled clusters, log messages, debug 
with -J-Dorg.netbeans.modules.ide.ergonomics.level=FINEST, etc.

Anyone else sees the problem?
Comment 6 Jindrich Sedek 2009-04-28 15:56:22 UTC
I'm not able to reproduce problem 1, but I can reproduce problem 2 using new server domain.  Tim, didn't you create new 
domain while adding server? See issue #163940.
Comment 7 Jaroslav Tulach 2009-04-30 11:58:07 UTC
I am trying to reproduce the problem in revision 4fffdce28e98:

problem 1 seems to be gone. I can see ~12 server plugins in Add Server Instance dialog.

problem 2 seems to be gone too. If I install GFv3 and wait a while the combo is refereshed with filled with proper 
instance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo