Bug 163357 - adding a server does not honor port change
adding a server does not honor port change
Status: NEW
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 9
6.x
All All
: P4 (vote)
: TBD
Assigned To: Vince Kraemer
issues@serverplugins
:
: 84933 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 11:00 UTC by nagyz
Modified: 2010-02-02 06:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nagyz 2009-04-22 11:00:03 UTC
when I add a new glassfish v2 server and specify a port other than 4848, the value I entered is not used, instead the
default port is used everywhere, so I cannot deploy to it.

tested on 6.7M3
Comment 1 Vince Kraemer 2009-04-22 15:45:15 UTC
please provide the steps to reproduce the issue.
Comment 2 nagyz 2009-04-22 16:45:58 UTC
sure.

click on the services tab, right click on servers, then add server.
select glassfish v2.x, enter a name, select "register remote domain",
enter host, and change port to 24848 (in my case thats the actual port where
the server listens), then enter admin username/password, then select finish.

when I didnt see the green arrow besides the name, I got suspicous. so I moved the
cursor over the name, and what did I see? "servername:4848".

in the configuration file, it's written as 4848, so it disregards the port input completely.

if I close netbeans, change the port in the configuration file and start up netbeans again,
then it shows up as 24848, and works.
Comment 3 Vince Kraemer 2009-04-22 17:40:55 UTC
*** Issue 84933 has been marked as a duplicate of this issue. ***
Comment 4 Vince Kraemer 2009-04-22 17:41:33 UTC
work-around: use the arrows and/or be sure to tab out of the field before you close the dialog.

I am going to change the spinners into text fields, since the spinners have been more trouble than they are worth.
Comment 5 Vince Kraemer 2009-09-16 20:29:58 UTC
does not apply to v3, so this is a p4 issue for 6.8
Comment 6 jonathang 2010-02-02 06:16:33 UTC
Morning Everyone.
I get the same probleme with my Netbeans ID 6.7.1 and 6.8.
I got a glassfish serveur (SGES V2.1.1) install on a remote serveur.
Then after develop my applications with NB 6.7 cannot access to the GF serveur
the error message : <<Starting of server remoteGlassFishName is not supported. Please, start the server manually.
>>
whereas i got rigth configuration to acces remote GF serveur:
- as started GF on my own machine
- the rigth ipAdresse the remote GF
- the rigth port (24848)
- rigth user/password
- AND MY REMOTE GF has STARTED since long time ago

Thank for your help

sorry for my english i use to speak and write in french

JonyG


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo