Bug 162463 - [67cat] NullPointerException at javax.help.UniteAppendMerge.processMerge
[67cat] NullPointerException at javax.help.UniteAppendMerge.processMerge
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: issues@javaee
issues@javaee
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 02:31 UTC by theshadow27
Modified: 2009-05-29 14:20 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description theshadow27 2009-04-12 02:31:44 UTC
Clicking help buttons triggers a NPE. This was from the "platform" menu in 200904111401
Comment 1 theshadow27 2009-04-12 02:36:17 UTC
1) Open build 200904111401
2) Click Tools -> Java Platforms
3) Click "Help" button in lower right hand corner

NPE is triggered on first run. This is on a fresh user directory. 
Comment 2 neilg 2009-04-14 17:45:58 UTC
I first saw this issue when clicking the Help > Help Contents menu. A result of this exception is that there is no TOC
in the help window.
Comment 3 Masaki Katakai 2009-05-24 12:10:01 UTC
This should be P1 - I'm still seeing this issue on build 200905231401.
It looks /org/netbeans/modules/web/helpset/docs/web-toc.xml is not correct.

Parsing failed for nbdocs:/org/netbeans/modules/web/helpset/docs/web-toc.xml
Exception caught while parsing nbdocs:/org/netbeans/modules/web/helpset/docs/web-toc.xmljava.util.EmptyStackException
SEVERE [org.openide.util.Exceptions]
java.lang.NullPointerException
        at javax.help.UniteAppendMerge.processMerge(UniteAppendMerge.java:70)
        at javax.help.plaf.basic.BasicTOCNavigatorUI.doMerge(BasicTOCNavigatorUI.java:429)
        at javax.help.plaf.basic.BasicTOCNavigatorUI.addSubHelpSets(BasicTOCNavigatorUI.java:316)
        at javax.help.plaf.basic.BasicTOCNavigatorUI.loadData(BasicTOCNavigatorUI.java:228)
        at javax.help.plaf.basic.BasicTOCNavigatorUI.access$000(BasicTOCNavigatorUI.java:75)
        at javax.help.plaf.basic.BasicTOCNavigatorUI$NavSwingWorker.construct(BasicTOCNavigatorUI.java:262)
        at com.sun.java.help.impl.SwingWorker$2.run(SwingWorker.java:139)
[catch] at java.lang.Thread.run(Thread.java:637)
Comment 4 _ ludo 2009-05-24 19:57:36 UTC
P2: Same behaviour when click on the popup menu Server->Identity Usage

Not sure why we have this Identity Usage Popup menu there either....Not consistent with help system at all


Upload of NetBeans Error Report Complete
Your report has been classified as a duplicate of report #22361. It has now been added to the database as exception #207508.
We will endeavor to find the cause of the problem. This issue was already reported in the Issuezilla tracking system.
You can view progress and get or provide more information directly at issue 162463.
Additional comments:
1) Open build 200904111401 2) Click Tools -> Java Platforms 3) Click "Help" button in lower right hand corner NPE is
triggered on first run. This is on a fresh user directory.
Thanks again for your help.  The NetBeans development team!
Comment 5 _ ludo 2009-05-24 19:59:13 UTC
Product Version: NetBeans IDE Dev (Build 200905240201)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: SunOS version 5.11 running on x86; UTF-8; en_US (nb)
Userdir: /export/home/ludo/.netbeans/dev
Comment 6 Ivan Sidorkin 2009-05-25 07:35:52 UTC
>>Parsing failed for nbdocs:/org/netbeans/modules/web/helpset/docs/web-toc.xml

reassigned to web for evaluation
Comment 7 Michal Mocnak 2009-05-25 10:53:26 UTC
Marking as P1. It's 100% reproducible and it should be fixed in rc1.
Comment 8 Petr Hejl 2009-05-25 12:42:48 UTC
Fixed in web-main c9326b1ceea7.
Comment 9 Petr Jiricka 2009-05-25 16:04:07 UTC
Thanks many times, Petr - Martin S will verify.
Comment 10 Martin Schovanek 2009-05-25 22:20:39 UTC
Fix verified in continuous build by QE.
Comment 11 Quality Engineering 2009-05-26 07:29:49 UTC
Integrated into 'main-golden', will be available in build *200905260201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c9326b1ceea7
User: phejl@netbeans.org
Log: #162463 [67cat] NullPointerException at javax.help.UniteAppendMerge.processMerge
Comment 12 Tomas Mysik 2009-05-26 09:36:23 UTC
Patch is OK.
Comment 13 Petr Hejl 2009-05-27 09:51:09 UTC
Fixed in release67 f4d2e72c576b.
Comment 14 Michal Mocnak 2009-05-29 14:20:33 UTC
Verified in nb67rc1 build #200905282243


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo