Bug 162411 - IDE pegs cpu
IDE pegs cpu
Status: RESOLVED INVALID
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
All Windows XP x64
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: PERFORMANCE, RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 15:46 UTC by fmcorp
Modified: 2009-08-19 13:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fmcorp 2009-04-10 15:46:12 UTC
Product Version: NetBeans IDE 6.5.1 (Build 200903060201)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Windows XP version 5.2 running on x86; Cp1252; en_US (nb)
Userdir: C:\Documents and Settings\<username>\.netbeans\6.5

-------------

While editing or scrolling the editor window, the whole IDE locks up.  java.exe*32 pegs CPU at 100% on one CPU for
several seconds, then finally everything frees back up for a short while.

I think it pegs during either a re-formatting process or during the compilation process.

Thanks
Comment 1 Jiri Prox 2009-04-14 12:03:41 UTC
Can you please capture several threaddumps when IDE does not respond?
Thanks

http://wiki.netbeans.org/GenerateThreadDump
Comment 2 Vitezslav Stejskal 2009-04-20 13:28:03 UTC
Without the threaddumps there is not much we can do. Sorry.
Comment 3 Jiri Prox 2009-08-19 13:45:12 UTC
Unfortunately there is no feedback from reported, I'm afraid that without requested info we cannot do anything about it,
since we weren't able to reproduce it, Closing as Invalid for now.

Feel free to reopen and provide requested info if it is still reproducible
thanks 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo