Bug 162058 - IllegalStateException: The data object C:\Source\5.4\Applications\swCommunity\web\calendarWeek.jsp is invalid; you may not call getNodeDelegate on it any more; see #17020 and please fix your code
IllegalStateException: The data object C:\Source\5.4\Applications\swCommunity...
Status: RESOLVED DUPLICATE of bug 153008
Product: platform
Classification: Unclassified
Component: Data Systems
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 17:26 UTC by trobbins
Modified: 2009-05-05 14:51 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.94 KB, text/plain)
2009-04-06 17:26 UTC, trobbins
Details
stacktrace (6.34 KB, text/plain)
2009-04-07 00:04 UTC, ksilz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description trobbins 2009-04-06 17:26:01 UTC
Build: NetBeans IDE Dev (Build 200904011705)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments:
trobbins: installed NB 6.7 m3.  
chose to import profile from NB 6.5.1.  
opened up a jsp in  a free-form web project



Stacktrace: 
java.lang.IllegalStateException: The data object C:\Source\5.4\Applications\swCommunity\web\calendarWeek.jsp is invalid; you may not call getNodeDelegate on it any more; see #17020 and please fix your code
        at org.openide.loaders.DataObject.getNodeDelegate(DataObject.java:270)
        at org.openide.loaders.DataObject.getClonedNodeDelegate(DataObject.java:306)
        at org.openide.loaders.FolderChildren.createNodes(FolderChildren.java:207)
        at org.openide.loaders.FolderChildren.createNodes(FolderChildren.java:66)
        at org.openide.nodes.Children$Keys$KE.nodes(Children.java:1608)
        at org.openide.nodes.EntrySupport$Lazy$EntryInfo.getNode(EntrySupport.java:1554)
Comment 1 trobbins 2009-04-06 17:26:12 UTC
Created attachment 79549 [details]
stacktrace
Comment 2 ksilz 2009-04-07 00:04:37 UTC
Build: NetBeans IDE Dev (Build 200904011705)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments: 
Deleted plug-in folder in Grails project after upgrading to Grails 1.1.

Stacktrace: 
java.lang.IllegalStateException: The data object D:\source\NetBeansProjects\SeldonManager2\plugins\grails-dynamic-jasper-0.2.zip is invalid; you may not call getNodeDelegate on it any more; see #17020 and please fix your code
        at org.openide.loaders.DataObject.getNodeDelegate(DataObject.java:270)
        at org.openide.loaders.DataObject.getClonedNodeDelegate(DataObject.java:306)
        at org.openide.loaders.FolderChildren.createNodes(FolderChildren.java:207)
        at org.openide.loaders.FolderChildren.createNodes(FolderChildren.java:66)
        at org.openide.nodes.Children$Keys$KE.nodes(Children.java:1608)
        at org.openide.nodes.EntrySupport$Lazy$EntryInfo.getNode(EntrySupport.java:1554)
Comment 3 ksilz 2009-04-07 00:04:52 UTC
Created attachment 79573 [details]
stacktrace
Comment 4 Jiri Skrivanek 2009-04-07 07:45:09 UTC
Not sure what can we do with this. DataObject is valid in FolderChildren.createNodes but probably some other thread make
it invalid before it comes to DataObject.getNodeDelegate. Further synchronization is probably risky.
Comment 5 Jiri Skrivanek 2009-05-05 14:51:08 UTC

*** This issue has been marked as a duplicate of 153008 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo