Bug 161517 - [67cat] NPE in GLF parser
[67cat] NPE in GLF parser
Status: VERIFIED FIXED
Product: obsolete
Classification: Unclassified
Component: languages
6.x
PC Linux
: P1 with 4 votes (vote)
: 6.x
Assigned To: sunbiz
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 20:16 UTC by mbien
Modified: 2009-06-11 21:31 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
exceptions from IDE log (2.80 KB, text/plain)
2009-03-30 20:18 UTC, mbien
Details
As far as I can tell after my change schlieman is working as good as it used to (61.63 KB, image/png)
2009-05-20 18:08 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mbien 2009-03-30 20:17:04 UTC
[ JDK VERSION : 1.6.* ]

Schlieman (GLF) does not work with NetBeans 6.7.

how to reproduce:
-make sure GLF is installed by installing ether an editor which uses
GLF or download and install the nbm directly
http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastSuccessfu
lBuild/artifact/nbbuild/nbms/extra/org-netbeans-modules-languages.nbm
-open a valid .nbs file (or any other file which uses an editor based
on the GLF framework e.g Velocity script)
-open NB log file, you should see several ParseExceptions

consequences:
all AST based features like navigator, completion, syntax checks,
semantic highlighting etc do not work.
Comment 1 mbien 2009-03-30 20:18:29 UTC
Created attachment 79087 [details]
exceptions from IDE log
Comment 2 mgoe 2009-04-30 14:32:11 UTC
We are using the Schliemann framework in our product and we are very concerned that nobody seems to care about this 
problem. Therefore I would suggest raising the priority of this bug to P1 because the Bug Priority Guidelines say: 
P1 "doesn't work no workaround exists"
Comment 3 mbien 2009-04-30 15:11:51 UTC
increased priority to P1
Comment 4 Jiri Kovalsky 2009-05-13 16:21:26 UTC
Saptarshi, can you please try to fix this 6.7 showstopper issue? Thanks a lot!
Comment 5 Jaroslav Tulach 2009-05-20 17:19:10 UTC
If I do:

cd languages
hg revert -r release65_beta .

then this bug is gone and schlieman starts to work the same as it used to in release65 - e.g. full compatibility 
guaranteed.
Comment 6 Jaroslav Tulach 2009-05-20 18:08:57 UTC
Created attachment 82501 [details]
As far as I can tell after my change schlieman is working as good as it used to
Comment 7 Jaroslav Tulach 2009-05-21 14:22:06 UTC
ergonomics#95a684b5b0b7
Comment 8 mbien 2009-06-11 21:31:58 UTC
verified in 6.7 RC2. Schlieman works as with 6.5. Thank you for not breaking compatibility ;)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo