Bug 161045 - Snapshot not opened
Snapshot not opened
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Petr Cyhelsky
issues@profiler
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 16:18 UTC by Ivan Sidorkin
Modified: 2009-05-22 13:19 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (39.53 KB, text/plain)
2009-03-24 16:20 UTC, Ivan Sidorkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2009-03-24 16:18:06 UTC
Product Version         = NetBeans IDE Dev (Build 200903231401)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19; Sun Microsystems Inc.

reproduced on WinXP and MacOS
full installer with ergonomics

- create PHP Application
- create Ruby Application
- create Java Application
- start memory profiling 
- after finishing application click Yes to take snapshot 

snapshot not opened, but if you will try to close NB it will say that you have unsaved snapshot
reproducible only with enabled ergonomics
was not able to reproduce if only PHP or only Ruby app was created before Java app
Comment 1 Ivan Sidorkin 2009-03-24 16:20:44 UTC
Created attachment 78765 [details]
messages.log
Comment 2 Jaroslav Tulach 2009-04-09 12:23:55 UTC
Profile guys, you promised me to evaluate the problem. So we know what is necessary step to fix it.
Comment 3 Tomas Hurka 2009-04-09 13:38:21 UTC
Petr was investigating it. 
Comment 4 Petr Cyhelsky 2009-04-16 13:21:52 UTC
After the fix of Issue #135532 the problem can no longer be reproduced on my system as it used to. It seems both were
caused by the same underlying problem. Please try reproducing it on build 200904160201 or later. Until reproduced
marking as worksforme.
Comment 5 Ivan Sidorkin 2009-04-16 13:51:06 UTC
now it works fine
Comment 6 Ivan Sidorkin 2009-04-22 15:14:08 UTC
reproduced with Beta 200904220001 
after adding one more step:

- create PHP Application
- create Ruby Application
- create Java Application
- open NPW, select Java Web->Web Application, click next and press ESC during feature activating
(sometime NPE thrown Issue 163176)
- start memory profiling 
- after finishing application click Yes to take snapshot 

snapshot not opened, but if you will try to close NB it will say that you have unsaved snapshot

Comment 7 Petr Cyhelsky 2009-04-27 14:26:24 UTC
fixed in profiler-main: 128911:f3c2084e6630
Comment 8 Quality Engineering 2009-04-29 18:43:34 UTC
Integrated into 'main-golden', will be available in build *200904291401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f3c2084e6630
User: Petr Cyhelsky <cyhelsky@netbeans.org>
Log: #161045 Prevent ResultsManager from being garbage collected, causing loss of registered listeners
Comment 9 Ivan Sidorkin 2009-05-05 09:06:33 UTC
verified with  NetBeans IDE Dev (Build 200905050201)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo