Bug 159526 - java.net.URISyntaxException
java.net.URISyntaxException
Status: RESOLVED DUPLICATE of bug 159022
Product: platform
Classification: Unclassified
Component: Module System
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 14:25 UTC by Peter Nabbefeld
Modified: 2009-03-03 16:13 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Nabbefeld 2009-03-03 14:25:28 UTC
I've got several errors like this in my log file:

SEVERE [org.openide.util.Exceptions]
java.net.URISyntaxException: Illegal character in path at index 27: file:/C:/Programme/NetBeans Dev
200903021401/platform10/core/core.jar
        at java.net.URI$Parser.fail(URI.java:2809)
        at java.net.URI$Parser.checkChars(URI.java:2982)
        at java.net.URI$Parser.parseHierarchical(URI.java:3066)
        at java.net.URI$Parser.parse(URI.java:3014)
        at java.net.URI.<init>(URI.java:578)
        at java.net.URL.toURI(URL.java:918)
[catch] at org.netbeans.core.startup.ModuleSystem.loadBootModules(ModuleSystem.java:204)
        at org.netbeans.core.startup.Main.getModuleSystem(Main.java:166)
        at org.netbeans.core.startup.Main.start(Main.java:309)
        at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:110)
        at java.lang.Thread.run(Thread.java:619)
SEVERE [org.openide.util.Exceptions]
java.net.URISyntaxException: Illegal character in path at index 27: file:/C:/Programme/NetBeans Dev
200903021401/platform10/core/org-openide-filesystems.jar
        at java.net.URI$Parser.fail(URI.java:2809)
        at java.net.URI$Parser.checkChars(URI.java:2982)
        at java.net.URI$Parser.parseHierarchical(URI.java:3066)
        ...

Sth. seems to have been changed in the past days (possibly about two weeks). I'd be glad, if this could be fixed
urgently, as this might cause other problems (as it seems, some core jars are probably not loaded correctly).

The problem with the URI are the space characters, but they worked in the past.
Comment 1 Jesse Glick 2009-03-03 16:13:13 UTC

*** This issue has been marked as a duplicate of 159022 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo