Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 159244 - NullPointerException at org.openide.nodes.FilterNode.<init>
NullPointerException at org.openide.nodes.FilterNode.<init>
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Code
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: issues@serverplugins
issues@serverplugins
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 18:00 UTC by Jindrich Sedek
Modified: 2009-03-16 16:17 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.28 KB, text/plain)
2009-03-05 14:59 UTC, msilverboard
Details
stacktrace (7.28 KB, text/plain)
2009-03-05 20:59 UTC, msilverboard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2009-02-26 18:00:55 UTC
Opened tools->servers menu.

Build: NetBeans IDE Dev (Build 200901200201)
VM: Java HotSpot(TM) Server VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Windows XP, 5.1, x86
User comments: 
STACKTRACE: (first 10 lines)
java.lang.NullPointerException
        at org.openide.nodes.FilterNode.<init>(FilterNode.java:198)
        at org.openide.nodes.FilterNode.<init>(FilterNode.java:179)
        at org.openide.nodes.FilterNode.<init>(FilterNode.java:170)
        at org.netbeans.modules.server.ui.manager.ServerManagerPanel$ServerNode.<init>(ServerManagerPanel.java:503)
        at org.netbeans.modules.server.ui.manager.ServerManagerPanel$ServersChildren.createNodeForKey
(ServerManagerPanel.java:469)
        at org.netbeans.modules.server.ui.manager.ServerManagerPanel$ServersChildren.createNodeForKey
(ServerManagerPanel.java:455)
        at org.openide.nodes.ChildFactory.createNodesForKey(ChildFactory.java:116)
        at org.openide.nodes.SynchChildren.createNodes(SynchChildren.java:78)
        at org.openide.nodes.Children$Keys$KE.nodes(Children.java:1602)
        at org.openide.nodes.ChildrenArray.nodesFor(ChildrenArray.java:168)
Comment 1 msilverboard 2009-03-05 14:59:42 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments: 
Just installed NetBeans, loaded plugins, and restarted it.  Clicked Tools > Servers, and boom: NullPointerException.

Stacktrace: 
java.lang.NullPointerException
        at org.openide.nodes.FilterNode.<init>(FilterNode.java:198)
        at org.openide.nodes.FilterNode.<init>(FilterNode.java:179)
        at org.openide.nodes.FilterNode.<init>(FilterNode.java:170)
        at org.netbeans.modules.server.ui.manager.ServerManagerPanel$ServerNode.<init>(ServerManagerPanel.java:503)
        at org.netbeans.modules.server.ui.manager.ServerManagerPanel$ServersChildren.createNodeForKey(ServerManagerPanel.java:469)
        at org.netbeans.modules.server.ui.manager.ServerManagerPanel$ServersChildren.createNodeForKey(ServerManagerPanel.java:455)
Comment 2 msilverboard 2009-03-05 14:59:46 UTC
Created attachment 77769 [details]
stacktrace
Comment 3 msilverboard 2009-03-05 15:40:25 UTC
When I installed NetBeans, I installed it with Tomcat, but no GlassFish servers. After opening the Add Servers dialog 
and clicking through the NullPointerException message, the only server I see available is Jetty (Grails 1.0.3), since 
I've got a Grails project.  Where's Tomcat?  

If I try to add a server, an error message pops up telling me that "No server plugins are installed in the IDE. The 
IDE needs a server plugin (e.g. GlassFish plugin) to enable registering and using a server. Use Plugins Manager to 
install server plugins."

Missing plugins may be the cause of the NPE. I'm a bit unhappy about your decision to tie the server management 
interface to the GlassFish plugin though. Why should I have to install an entire new app server just to be able to 
manage Tomcat??
Comment 4 msilverboard 2009-03-05 20:59:24 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments: 
See Issue 171544.  I have reinstalled, this time, including GlassFish server.  Error still occurs when I open Tools > Servers.

Stacktrace: 
java.lang.NullPointerException
        at org.openide.nodes.FilterNode.<init>(FilterNode.java:198)
        at org.openide.nodes.FilterNode.<init>(FilterNode.java:179)
        at org.openide.nodes.FilterNode.<init>(FilterNode.java:170)
        at org.netbeans.modules.server.ui.manager.ServerManagerPanel$ServerNode.<init>(ServerManagerPanel.java:503)
        at org.netbeans.modules.server.ui.manager.ServerManagerPanel$ServersChildren.createNodeForKey(ServerManagerPanel.java:469)
        at org.netbeans.modules.server.ui.manager.ServerManagerPanel$ServersChildren.createNodeForKey(ServerManagerPanel.java:455)
Comment 5 msilverboard 2009-03-05 20:59:30 UTC
Created attachment 77784 [details]
stacktrace
Comment 6 Petr Hejl 2009-03-10 12:27:09 UTC
Fixed in web-main d36b5db5af1b. However if this is a bug in server plugin not intentionally returning null it won't be
visible in Server Manager. Adding Vince on cc as the gfv3 is the only server plugin actively developed right now.
Comment 7 Quality Engineering 2009-03-11 10:12:51 UTC
Integrated into 'main-golden', will be available in build *200903110259* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d36b5db5af1b
User: phejl@netbeans.org
Log: #159244 NullPointerException at org.openide.nodes.FilterNode.<init>
Comment 8 Jindrich Sedek 2009-03-16 16:17:11 UTC
verified.
NetBeans IDE Dev (090316)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo