Bug 158771 - IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
IllegalStateException: Should not acquire Children.MUTEX while holding Projec...
Status: RESOLVED DUPLICATE of bug 150540
Product: java
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jan Jancura
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 19:07 UTC by Tomas Mysik
Modified: 2009-03-17 15:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2009-02-18 19:07:23 UTC
See issue #148927 (comment #8 and #9) for more information.
Thanks.

        at org.openide.filesystems.FileObject.delete(FileObject.java:359)
        at org.netbeans.modules.java.j2seproject.ui.customizer.J2SEProjectProperties.checkModified(J2SEProjectProperties.java:445)
        at
org.netbeans.modules.java.j2seproject.ui.customizer.CustomizerProviderImpl$OptionListener.actionPerformed(CustomizerProviderImpl.java:
        at org.netbeans.modules.project.uiapi.CustomizerDialog$OptionListener$1.run(CustomizerDialog.java:213)
        at org.openide.util.Mutex.writeAccess(Mutex.java:394)
        at org.netbeans.modules.project.uiapi.CustomizerDialog$OptionListener.actionPerformed(CustomizerDialog.java:211)
Comment 1 Tomas Mysik 2009-02-18 19:10:59 UTC
From http://statistics.netbeans.org/exceptions/exception.do?id=164961:
NB build 090218
Mac OS X
Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
Comment 2 Tomas Mysik 2009-02-18 19:11:53 UTC
pstehlik: changed JVM from standard configured 1.5 to custom configured 1.5 and pressed OK
Comment 3 Jan Jancura 2009-02-19 14:24:16 UTC
looks like a bug
Comment 4 David Strupl 2009-03-17 15:19:56 UTC
This is the same problem as in #150540. I will write an additional comment there.

*** This issue has been marked as a duplicate of 150540 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo