Bug 15874 - ArrayIndexOutOfBoundsException from terminalemulator.Line.setCharacterAttribute
ArrayIndexOutOfBoundsException from terminalemulator.Line.setCharacterAttribute
Status: CLOSED FIXED
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: akemr
ivan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 20:18 UTC by Jesse Glick
Modified: 2008-12-23 08:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace and also contents of output window (3.66 KB, text/plain)
2001-09-24 20:19 UTC, Jesse Glick
Details
Sample module JAR (with intentional error in dataloader) (5.59 KB, application/octet-stream)
2001-09-26 13:44 UTC, Jesse Glick
Details
Matching .jarContent; note: also broken in [dev oct 4] (1.33 KB, application/octet-stream)
2001-10-05 15:44 UTC, Jesse Glick
Details
Module JAR file (new attempt) - test.jar (5.59 KB, application/octet-stream)
2001-10-09 08:52 UTC, Jesse Glick
Details
Matching test.jarContent (1.29 KB, application/octet-stream)
2001-10-09 08:53 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2001-09-24 20:18:44 UTC
[dev sep 23] Exception thrown from terminal while reinstalling a
module. Output is truncated in the middle of a line (large stack trace
with many hyperlinked lines). Happened repeatedly under the same
circumstances, not sure why these in particular.
Comment 1 Jesse Glick 2001-09-24 20:19:12 UTC
Created attachment 2680 [details]
Stack trace and also contents of output window
Comment 2 akemr 2001-09-25 14:21:39 UTC
I cannot reproduce it. However I found (from stack trace info) some 
fishy piece of code and fix it.
Jesse, is it OK now? If not, could you please send me (or attach) more
info? (reinstalled module..)
Thanks.
Comment 3 Jesse Glick 2001-09-26 13:43:28 UTC
I can still reproduce it in a build from Tue Sep 25 (evening, after
your fix I believe). I will attach the JAR file I am trying to
reinstall, see if you can reproduce it. Just click Execute on the JAR.
Comment 4 Jesse Glick 2001-09-26 13:44:29 UTC
Created attachment 2707 [details]
Sample module JAR (with intentional error in dataloader)
Comment 5 Jesse Glick 2001-10-03 10:15:43 UTC
I am raising the priority on this one because I find it occurring
frequently, with no apparent workaround, and preventing me from using
the Output Window (and thus the IDE) at all for certain tasks. E.g.
when running certain unit tests that reliably trigger the bug because
of their output, I am forced to use the command line to run them
because it is impossible to see their output from the IDE (even
redirecting output to a file truncates it incorrectly at the spot
where the bug occurs).

I saw it reproducibly in [dev oct 1], always when printing a large
stack trace. E.g. when I inserted a Thread.dumpStack() into a spot in
a unit test that would be run two or three times, the OW would print
the first stack trace fine (with hyperlinking), and get about halfway
through the second one (always to the same place) before throwing this
exception. At that point the remainder of the second stack trace was
never printed (though some other output coming later was printed to
the OW). Just mount lots of IDE sources and start printing stack
traces, it should not be hard to reproduce.
Comment 6 Jesse Glick 2001-10-05 15:40:34 UTC
It's still broken in [dev oct 3]. I will attach also the .jarContents
I used.
Comment 7 Jesse Glick 2001-10-05 15:44:35 UTC
Created attachment 2878 [details]
Matching .jarContent; note: also broken in [dev oct 4]
Comment 8 Jesse Glick 2001-10-09 08:52:47 UTC
Created attachment 2910 [details]
Module JAR file (new attempt) - test.jar
Comment 9 Jesse Glick 2001-10-09 08:53:53 UTC
Created attachment 2911 [details]
Matching test.jarContent
Comment 10 akemr 2001-10-09 13:52:52 UTC
Finally reproduced and fixed in main trunk.

Note: To reproduce you should also:
- run IDE with netbeans.debug.exceptions=on
- mount core/src and openide/src
Comment 11 Marian Mirilovic 2002-04-17 13:43:54 UTC
It seems like it works fine now, I cannot reproduce it.

verified
Comment 12 Quality Engineering 2003-07-01 16:44:19 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 13 Quality Engineering 2008-12-23 08:20:08 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo