Bug 158677 - REGRESSION: Can't add or edit abilities
REGRESSION: Can't add or edit abilities
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Build System
6.x
All Windows XP
: P1 (vote)
: 6.x
Assigned To: Petr Suchomel
issues@mobility
65fixes3-verified
:
Depends on:
Blocks: 154624
  Show dependency treegraph
 
Reported: 2009-02-17 15:05 UTC by Andrei Chistiakov
Modified: 2009-03-16 16:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Abilities panel with values (4.37 KB, image/png)
2009-02-17 15:49 UTC, Petr Suchomel
Details
Sample app (20.69 KB, application/x-compressed)
2009-02-17 16:15 UTC, Andrei Chistiakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Chistiakov 2009-02-17 15:05:44 UTC
Product Version: NetBeans IDE Dev (Build 200902161401)
Java: 1.6.0_10; Java HotSpot(TM) Server VM 11.0-b15
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

To reproduce:
- create a new Mobile Application;
- open project's properties;
- select Abilities;
- press Add or Edit button;
- try to enter or change ability name or value.

If more than 1 character is changed, OK button becomes disabled and the ability name/value pair can't be saved.
Comment 1 Petr Suchomel 2009-02-17 15:43:06 UTC
It works for me, see attached picture
Comment 2 Petr Suchomel 2009-02-17 15:49:22 UTC
Created attachment 77078 [details]
Abilities panel with values
Comment 3 Andrei Chistiakov 2009-02-17 15:56:28 UTC
It's strange. Except me, Ivan and Andrey have reproduced the issue on different machines.
Comment 4 Petr Suchomel 2009-02-17 16:02:47 UTC
Do you have a sample project? Was that JDK6_u10 or u12? In second case, I would understand there could be some, already
fixed issue. 
Comment 5 Andrei Chistiakov 2009-02-17 16:14:30 UTC
The project is attached. It's a project created using New Mobile Application wizard with all defaults.
Java version is 1.6.0_10
Comment 6 Andrei Chistiakov 2009-02-17 16:15:47 UTC
Created attachment 77082 [details]
Sample app
Comment 7 Andrei Chistiakov 2009-02-18 13:22:39 UTC
Product Version: NetBeans IDE Dev (Build 200902180201)
Java: 1.6.0_12; Java HotSpot(TM) Client VM 11.2-b01
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

The same issue appears with the following dialogs:
- Add Attribute;
- Edit Attribute;
- Add MIDlet;
- Edit MIDlet;
- Add Premission For API

while editing Application Descriptor via project properties.


Comment 8 Petr Suchomel 2009-02-18 13:58:54 UTC
This is connected with isValid() issue fix
Comment 9 Petr Suchomel 2009-02-18 14:24:30 UTC
Fixed in CS d29a432c8400
Comment 10 Quality Engineering 2009-02-22 07:55:09 UTC
Integrated into 'main-golden', will be available in build *200902220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d29a432c8400
User: psuchomel@netbeans.org
Log: Fix for #158677, REGRESSION: Can't add or edit abilities
Comment 11 Andrei Chistiakov 2009-02-24 08:53:07 UTC
Verified with M2 build NetBeans IDE Dev (Build 200902231810).
Comment 12 mslama 2009-03-02 14:58:12 UTC
release65_fixes #d741d0f470be
Comment 13 Andrei Chistiakov 2009-03-05 16:12:16 UTC
Verified with NetBeans IDE 6.5.1 (Build 200903050001)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo