Bug 158570 - Remote Breakpoints broken under 1.4.3
Remote Breakpoints broken under 1.4.3
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
Macintosh Linux
: P2 (vote)
: 6.x
Assigned To: Egor Ushakov
issues@cnd
65fixes3-fixed
: REGRESSION
: 158762 (view as bug list)
Depends on:
Blocks: 158762
  Show dependency treegraph
 
Reported: 2009-02-14 18:37 UTC by dakaix
Modified: 2009-06-25 10:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dakaix 2009-02-14 18:37:21 UTC
The new version of the C++ module (1.4.3) distributed via Automatic Update in the IDE causes remote breakpoints not to function. The log shows that 
NetBeans is not using the remote path when setting breakpoints, but the local path. Log snippet below:

...
111-break-insert -f /Volumes/LB1/eskimo/EskimoD/server.cpp:23
109&"info proc\n"
109~"process 4197\n"
109~"cmdline = '/root/eskimo/EskimoD/dist/Debug/GNU-Linux-x86/eskimod'\n"
...

...
&"No source file named /Volumes/LB1/eskimo/EskimoD/server.cpp.\n"
111^done,bkpt={number="2",type="breakpoint",disp="keep",enabled="y",addr="<PENDING>",pending="/Volumes/LB1/eskimo/EskimoD/server.cpp:23",ti
mes="0"}
...

NetBeans is running under Mac OSX Leopard (10.5.6  - gdb-962) and compiling/debugging against Fedora 9 x64 (GDB 6.3.50-20050815). This issue is 
not limited to this project, and a simple hello world project also has the same issue. Also discussed here: http://forums.netbeans.org/viewtopic.php?
t=8638
Comment 1 dakaix 2009-02-14 18:39:35 UTC
This also affects the nightly builds and 7.0M1, since they already use the 1.4.3 module version.
Comment 2 Vladimir Voskresensky 2009-02-15 09:47:32 UTC
Do you mean, this is regression after 6.5 made Auto Update? And before Auto update it worked fine?
Comment 3 dakaix 2009-02-15 11:03:43 UTC
Yes thats correct. If you download the current GA release of 6.5, remote breakpoints work. As soon as you Auto Update, they get broken.
Comment 4 Alexander Pepin 2009-02-20 14:56:34 UTC
The regression happened after fixing issue #151761
Comment 5 Egor Ushakov 2009-02-24 10:35:54 UTC
fixed in the changeset:
http://hg.netbeans.org/main/rev/4b3d0cdf0422
Comment 6 Egor Ushakov 2009-02-24 14:28:28 UTC
*** Issue 158762 has been marked as a duplicate of this issue. ***
Comment 7 Alexander Pepin 2009-02-26 21:00:42 UTC
Remote breakpoints now work but current position is not shown while debugging in makefile based projects.  
Comment 8 Alexander Pepin 2009-02-27 13:34:22 UTC
Current position was not shown due to old version of Gdb installed on the remote host. After installation of a newer Gdb
everithing works OK. 
Comment 9 Egor Ushakov 2009-02-27 16:45:05 UTC
integrated into release65_fixes with:
http://hg.netbeans.org/release65_fixes/rev/ee8e683f1548
Comment 10 Alexander Pepin 2009-03-03 18:00:52 UTC
in 6.5.1 clone breakpoints do not work for makefile (work fine for managed projects) based projects on
Solaris_x86/Solaris_sparc configuration when project is created on local machine in /export/home/tester and is mapped to
/net/sqao24/export/home/tester on remote host.
Comment 11 Alexander Pepin 2009-03-03 18:49:53 UTC
Somehow that wrong behavior is not reproducible any more. Please ignore the previous comment.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo