Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 158468 - Assertion and broken functionality for web services or clients from wsdl
Assertion and broken functionality for web services or clients from wsdl
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@webservices
:
: 156728 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 15:15 UTC by Jaroslav Pospisil
Modified: 2011-10-26 06:55 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2009-02-12 15:15:32 UTC
Build 200902120201,JDK1.6, Win Vista

1) Start IDE with new userdir
2) Create new Web Application on Glassfish v2
3) Create new web service from WSDL (use http://www.esynaps.com/WebServices/SearchWS.asmx?WSDL )
4) Wait until all actions are done.
ERROR:
1) No web service is displayed in editor, until wsimport is done.
2) After it's done, AssertionError is displayed (see below)
3) Even then,if I try to switch from Java view to any of others, I get the same assertion)

WARNING [global]: Error in source for css properties model for property: z-index
classLoader = org.netbeans.modules.web.jspparser_ext.WebAppParseSupport$ParserClassLoader@178eddf, parent :
org.netbeans.modules.web.jspparser.JspParserImpl$ExtClassLoader@13dad9c
SharedSecrets.getJavaNetAccess()=java.net.URLClassLoader$7@49008b
classLoader = org.netbeans.modules.web.jspparser_ext.WebAppParseSupport$ParserClassLoader@fbe715, parent :
org.netbeans.modules.web.jspparser.JspParserImpl$ExtClassLoader@13dad9c
SharedSecrets.getJavaNetAccess()=java.net.URLClassLoader$7@49008b
WARNING [org.netbeans.modules.subversion]: Could not load the file C:\Users\jp154641\AppData\Roaming\Subversion/config.
Falling back on svn defaults.
WARNING [org.netbeans.modules.subversion]: Could not load the file C:\Users\jp154641\AppData\Roaming\Subversion/servers.
Falling back on svn defaults.
SEVERE [org.openide.util.Exceptions]
java.lang.AssertionError: Data object
C:/Users/jp154641/Documents/NetBeansProjects/WebApplication6/src/conf/xml-resources/web-services/NewWebServiceFromWSDL/wsdl/SearchWSService.wsdl
has no editor cookies.
        at org.netbeans.modules.xml.retriever.catalog.Utilities._getDocument(Utilities.java:521)
        at org.netbeans.modules.xml.retriever.catalog.Utilities.access$000(Utilities.java:104)
        at org.netbeans.modules.xml.retriever.catalog.Utilities$1.getLookup(Utilities.java:637)
        at org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:77)
        at org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:152)
        at org.netbeans.modules.xml.wsdl.model.WSDLModelFactory.getModel(WSDLModelFactory.java:76)
        at
org.netbeans.modules.websvc.editor.hints.WebServicesHintsProvider.initServiceMetadata(WebServicesHintsProvider.java:173)
        at org.netbeans.modules.websvc.editor.hints.WebServicesHintsProvider.run(WebServicesHintsProvider.java:128)
        at
org.netbeans.modules.websvc.editor.hints.WebServicesHintsProvider$ProblemFinderCompInfo.run(WebServicesHintsProvider.java:203)
        at org.netbeans.modules.java.source.JavaSourceAccessor$CancelableTaskWrapper.run(JavaSourceAccessor.java:288)
[catch] at org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:690)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
Comment 1 Milan Kuchtiak 2009-02-12 17:09:46 UTC
I Cannot reproduce the issue.

I see no problem with AssertionError.
In production build it will not appear.

I only fixed the potential NPE:
http://hg.netbeans.org/main?cmd=changeset;node=3b40ebb75bbe

The strange is that DataObject for wsdl file isn't recognized in your computer.
Please, report the problem to Data Loaders functionality.
Best would be to create a simple xml document and check if it is recognized by Netbeans DataLoader mechanism.
Comment 2 Jaroslav Pospisil 2009-02-17 16:14:42 UTC
Assertion still reproducible in 200902161401.Reopening.

Assertion of similar type reproduced also when creating web service client in Maven Simple archetype project (same URL
for wsdl). After assertion displays, I can't finish the wizard. When I restarted IDE(assertion keep coming again and
again as in previous case) and createn another ws client from different wsdl,everything returned to normal.
java.lang.AssertionError: Data object H:/SearchWSService.wsdl has no editor cookies.
	at org.netbeans.modules.xml.retriever.catalog.Utilities._getDocument(Utilities.java:521)
	at org.netbeans.modules.xml.retriever.catalog.Utilities.access$000(Utilities.java:104)
	at org.netbeans.modules.xml.retriever.catalog.Utilities$1.getLookup(Utilities.java:637)
	at org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:77)
	at org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:152)
	at org.netbeans.modules.xml.wsdl.model.WSDLModelFactory.getModel(WSDLModelFactory.java:76)
	at org.netbeans.modules.websvc.core.client.wizard.ClientInfo.isRpcEncoded(ClientInfo.java:1404)
	at org.netbeans.modules.websvc.core.client.wizard.ClientInfo.valid(ClientInfo.java:1144)
	at
org.netbeans.modules.websvc.core.client.wizard.WebServiceClientWizardDescriptor.isValid(WebServiceClientWizardDescriptor.java:134)
	at org.openide.WizardDescriptor.updateStateOpen(WizardDescriptor.java:887)
	at org.openide.WizardDescriptor.updateState(WizardDescriptor.java:831)
	at org.openide.loaders.TemplateWizard.updateState(TemplateWizard.java:731)
	at org.netbeans.modules.project.ui.NewFileWizard.updateState(NewFileWizard.java:118)
	at org.openide.WizardDescriptor$Listener.stateChanged(WizardDescriptor.java:1960)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:320)
	at
org.netbeans.modules.websvc.core.client.wizard.WebServiceClientWizardDescriptor.fireChangeEvent(WebServiceClientWizardDescriptor.java:98)
	at org.netbeans.modules.websvc.core.client.wizard.ClientInfo.updateTexts(ClientInfo.java:1344)
	at org.netbeans.modules.websvc.core.client.wizard.ClientInfo.access$1000(ClientInfo.java:127)
	at org.netbeans.modules.websvc.core.client.wizard.ClientInfo$9.insertUpdate(ClientInfo.java:571)
	at javax.swing.text.AbstractDocument.fireInsertUpdate(AbstractDocument.java:185)
	at javax.swing.text.AbstractDocument.handleInsertString(AbstractDocument.java:734)
	at javax.swing.text.AbstractDocument.insertString(AbstractDocument.java:693)
	at javax.swing.text.PlainDocument.insertString(PlainDocument.java:114)
	at javax.swing.text.AbstractDocument.replace(AbstractDocument.java:655)
	at javax.swing.text.JTextComponent.setText(JTextComponent.java:1693)
	at org.netbeans.modules.websvc.core.client.wizard.ClientInfo.jBtnBrowseActionPerformed(ClientInfo.java:493)
	at org.netbeans.modules.websvc.core.client.wizard.ClientInfo.access$300(ClientInfo.java:127)
	at org.netbeans.modules.websvc.core.client.wizard.ClientInfo$2.actionPerformed(ClientInfo.java:235)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.Component.processMouseEvent(Component.java:6134)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
	at java.awt.Component.processEvent(Component.java:5899)
	at java.awt.Container.processEvent(Container.java:2023)
	at java.awt.Component.dispatchEventImpl(Component.java:4501)
	at java.awt.Container.dispatchEventImpl(Container.java:2081)
	at java.awt.Component.dispatchEvent(Component.java:4331)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4301)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3965)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3895)
	at java.awt.Container.dispatchEventImpl(Container.java:2067)
	at java.awt.Window.dispatchEventImpl(Window.java:2458)
	at java.awt.Component.dispatchEvent(Component.java:4331)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:178)
	at java.awt.Dialog$1.run(Dialog.java:1047)
	at java.awt.Dialog$3.run(Dialog.java:1099)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1097)
	at org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:985)
	at org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:1019)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:1007)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:115)
	at org.openide.util.Mutex.doEventAccess(Mutex.java:1355)
	at org.openide.util.Mutex.readAccess(Mutex.java:268)
	at org.netbeans.core.windows.services.NbPresenter.show(NbPresenter.java:992)
	at java.awt.Component.show(Component.java:1447)
	at java.awt.Component.setVisible(Component.java:1400)
	at java.awt.Window.setVisible(Window.java:824)
	at java.awt.Dialog.setVisible(Dialog.java:987)
	at org.openide.loaders.TemplateWizard.instantiateImpl(TemplateWizard.java:495)
	at org.openide.loaders.TemplateWizard.instantiate(TemplateWizard.java:374)
	at org.netbeans.modules.project.ui.actions.NewFile.doPerform(NewFile.java:154)
	at org.netbeans.modules.project.ui.actions.NewFile.access$200(NewFile.java:80)
	at org.netbeans.modules.project.ui.actions.NewFile$PopupListener.actionPerformed(NewFile.java:349)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1225)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1266)
	at java.awt.Component.processMouseEvent(Component.java:6134)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
	at java.awt.Component.processEvent(Component.java:5899)
	at java.awt.Container.processEvent(Container.java:2023)
	at java.awt.Component.dispatchEventImpl(Component.java:4501)
	at java.awt.Container.dispatchEventImpl(Container.java:2081)
	at java.awt.Component.dispatchEvent(Component.java:4331)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4301)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3965)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3895)
	at java.awt.Container.dispatchEventImpl(Container.java:2067)
	at java.awt.Window.dispatchEventImpl(Window.java:2458)
	at java.awt.Component.dispatchEvent(Component.java:4331)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 3 Quality Engineering 2009-02-18 10:35:39 UTC
Integrated into 'main-golden', will be available in build *200902180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/3b40ebb75bbe
User: mkuchtiak@netbeans.org
Log: #158468:fixing potential NPE
Comment 4 Milan Kuchtiak 2009-02-18 13:51:40 UTC
This is related to "ergonomics" feature. Wsdl data object isn't recognized, then Utilities._getDocument() fails.
I need an assistance. What fix is the best.

From user perspective, I think, 
- unless wsdl (graphical) editor isn't installed, the wsdl can be recognized as normal XML document.

Suggested fix:
+++ b/xml/src/org/netbeans/modules/xml/resources/xml-mime-resolver.xml  Wed Feb 18 14:29:09 2009 +0100
@@ -47,6 +47,7 @@
 
     <file>
         <ext name="xml"/>
+        <ext name="wsdl"/>
         <resolver mime="text/xml"/>
     </file>

I wonder this is enough from ergonomics perspective. 
Adding J.Tulach to CC.
Comment 5 Jaroslav Tulach 2009-02-19 08:31:24 UTC
The general issue is that XML-like documents are present as "unknown" and not as "base XML". This is indeed very bad 
and I'll fix it. Is this still a blocker for M2?
Comment 6 Jaroslav Pospisil 2009-02-19 09:05:26 UTC
The issue affects multiple areas in multiple project types (both ant and maven projects,java and web app,web services
and clients from wsdl), all that previously worked well - so this is very nasty bug and definitely should be fixed in M2.
Comment 7 Jaroslav Tulach 2009-02-19 09:45:41 UTC
ergonomics#1cfd3b3b81c7
Comment 8 Jaroslav Pospisil 2009-02-19 14:41:10 UTC
Verified in mentioned build - issue is not reproducible there anymore.
Comment 9 Jaroslav Pospisil 2009-02-19 14:43:27 UTC
Jarda, commit please fix to M2 clone.
Comment 10 Jaroslav Tulach 2009-02-19 16:18:48 UTC
ergonomics#e84983560648
release67_m2#72032cf04804
Comment 11 Jaroslav Pospisil 2009-02-23 09:20:00 UTC
Verified in M2.
Comment 12 Petr Jiricka 2009-02-24 11:22:36 UTC
Still reproducible for me in dev build 200902231401 (from trunk). Looks like the change was not propagated to the dev build?
Comment 13 Jaroslav Pospisil 2009-02-24 13:09:00 UTC
I just reproduced it too. Jarda,could you please commit the fix also into trunk?
Comment 14 Jaroslav Tulach 2009-03-02 09:49:45 UTC
As soon as the change propagates to production build and main-golden (which is the only repository to represent the 
trunk, isn't it?), an automated note will be put into this issue. There is no way to speed this up (except not 
breaking the production build), I am afraid.
Comment 15 Quality Engineering 2009-03-02 20:54:51 UTC
Integrated into 'main-golden', will be available in build *200903021401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1cfd3b3b81c7
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #158468: Let the XML-like object be represented by default XMLDataObject.
This may need further improvements to allow users to enable the advanced functionality from pop-up menu,
but as a fix for a P1, this shall be enough.
Comment 16 Jaroslav Pospisil 2009-03-04 14:16:17 UTC
verified in trunk
Comment 17 Svata Dedic 2011-10-26 06:55:50 UTC
*** Bug 156728 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo