Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 158436 - Override completion (with ctrl) doesn't work properly with generic classes constructors
Override completion (with ctrl) doesn't work properly with generic classes co...
Status: RESOLVED DUPLICATE of bug 142225
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 08:42 UTC by proktor
Modified: 2009-02-19 20:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description proktor 2009-02-12 08:42:25 UTC
When I've got:
  
Deque<Integer> stack = new ArrayDeque<Integer>();

and want to change to LinkedList implementation with override completion (with ctrl) the result is:

Deque<Integer> stack = new LinkedList<Integer><Integer>();

Looks like override completion doesn't work in this case, and I believe it should.
Comment 1 Vitezslav Stejskal 2009-02-12 09:02:22 UTC
Reproducible in trunk.
Comment 2 Dusan Balek 2009-02-12 13:02:19 UTC
Already reported. Thanks. 

*** This issue has been marked as a duplicate of 142225 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo