Bug 157948 - NullPointerException at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.ServerChooserVisual.isServerValid
NullPointerException at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.S...
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Petr Hejl
issues@serverplugins
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes3-verified
:
: 162893 168784 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 23:40 UTC by aliberata
Modified: 2009-10-13 17:48 UTC (History)
17 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.86 KB, text/plain)
2009-02-04 23:40 UTC, aliberata
Details
stacktrace (7.44 KB, text/plain)
2009-02-13 10:18 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aliberata 2009-02-04 23:40:01 UTC
Build: NetBeans IDE 6.1 (Build 200805300101)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments:
GUEST: Right clicked on a project and selected the "Resolve Missing Server Problem". In the "Resolve Missing Server Problem" windows I clicked the button "Add Server...".

GUEST: Attempted to create a new Web project. The error appeared when I tried to register a web server.

GUEST: Trying to create new Enterprise Application. Exception occurs when trying to click "Add..." button on "Server and Settings" page.

GUEST: I am trying to register a server for the petstore sample application.  The exception occured when I clicked on the [Add Server...] button.



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.ServerChooserVisual.isServerValid(ServerChooserVisual.java:133)
        at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.ServerChooserVisual.isValid(ServerChooserVisual.java:125)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
Comment 1 aliberata 2009-02-04 23:40:06 UTC
Created attachment 76583 [details]
stacktrace
Comment 2 Vince Kraemer 2009-02-12 22:49:40 UTC
I think this is the bug that phejl spoke of in http://www.netbeans.org/issues/show_bug.cgi?id=150223#desc23

Petr: please confirm and close as you see fit.
Comment 3 Marian Mirilovic 2009-02-13 10:17:52 UTC
Build: NetBeans IDE Dev (Build 200902121452)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Linux, 2.6.27-11-generic, amd64

User Comments: 
Resolve Missing Server Problem - pushed "Add Server" button

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.ServerChooserVisual.isServerValid(ServerChooserVisual.java:133)
        at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.ServerChooserVisual.isValid(ServerChooserVisual.java:125)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
Comment 4 Marian Mirilovic 2009-02-13 10:18:03 UTC
Created attachment 76954 [details]
stacktrace
Comment 5 Petr Hejl 2009-02-13 10:25:26 UTC
This has been fixed in main 3caf7410e83f. Mentioned in issue 157948.
Comment 6 Jaroslav Pospisil 2009-03-05 16:49:30 UTC
verified in NB6.5.1 with Win Vista and JDK1.6.0_13
Comment 7 Petr Hejl 2009-04-17 10:33:14 UTC
*** Issue 162893 has been marked as a duplicate of this issue. ***
Comment 8 Petr Jiricka 2009-08-28 15:47:47 UTC
*** Issue 168784 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo